HDU1708 Fibonacci String【水题】

Fibonacci String


Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3652    Accepted Submission(s): 1259

Problem Description
After little Jim learned Fibonacci Number in the class , he was very interest in it.
Now he is thinking about a new thing -- Fibonacci String .

He defines : str[n] = str[n-1] + str[n-2] ( n > 1 ) 

He is so crazying that if someone gives him two strings str[0] and str[1], he will calculate the str[2],str[3],str[4] , str[5].... 

For example :
If str[0] = "ab"; str[1] = "bc";
he will get the result , str[2]="abbc", str[3]="bcabbc" , str[4]="abbcbcabbc" …………;

As the string is too long ,Jim can't write down all the strings in paper. So he just want to know how many times each letter appears in Kth Fibonacci String . Can you help him ?
 
Input
The first line contains a integer N which indicates the number of test cases.
Then N cases follow.
In each case,there are two strings str[0], str[1] and a integer K (0 <= K < 50) which are separated by a blank.
The string in the input will only contains less than 30 low-case letters.
 
Output
For each case,you should count how many times each letter appears in the Kth Fibonacci String and print out them in the format "X:N". 
If you still have some questions, look the sample output carefully.
Please output a blank line after each test case.

To make the problem easier, you can assume the result will in the range of int. 
 
Sample Input
1
ab bc 3
 
Sample Output
a:1
b:3
c:2
d:0
e:0
f:0
g:0
h:0
i:0
j:0
k:0
l:0
m:0
n:0
o:0
p:0
q:0
r:0
s:0
t:0
u:0
v:0
w:0
x:0
y:0

z:0


思路:水题。斐波那契数列变形。用数组存储字母个数是个小技巧。


#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;

char str1[40],str2[40];

int a[27],b[27],c[27];
int main()
{
    int T,K;
    cin >> T;
    while(T--)
    {
        getchar();
        memset(str1,0,sizeof(str1));
        memset(str2,0,sizeof(str2));
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        cin >> str1 >> str2 >> K;
        int len1 = strlen(str1);
        int len2 = strlen(str2);
        for(int i = 0; i < len1; i++)
        {
           a[str1[i]-'a']++;
        }
        for(int i = 0; i < len2; i++)
        {
            b[str2[i]-'a']++;
        }
        if(K == 0)
        {
            for(int i = 0; i < 26; i++)
            {
                cout << (char)(i+'a') << ":" << a[i] << endl;
            }
        }
        else if(K == 1)
        {
            for(int i = 0; i < 26; i++)
            {
                cout << (char)(i+'a') << ":" << b[i] << endl;
            }
        }
        else if(K >= 2)
        {
            for(int i = 2; i <= K; i++)
            {
                for(int j = 0; j < 26; j++)
                {
                    c[j] = a[j] + b[j];
                    a[j] = b[j];
                    b[j] = c[j];
                }
            }
            for(int i = 0; i < 26; i++)
                cout << (char)(i+'a') << ":" << c[i] << endl;
        }
        cout << endl;
    }

    return 0;
}



你可能感兴趣的:(HDU1708 Fibonacci String【水题】)