AreYouBusy
有n组工作,T时间,每个工作组中有m个工作,改组分类是s,s是0是组内至少要做一件,是1时最多做一件,2时随意,每项工作的描述是花费的时间和获得的快乐值,求在T时间内可获的最大快乐值。
s=0时必选,0组内的物品可以和上一可达状态组合(只放一件),也可以和当前的可达状态组合(放多件),为使0组内的物品一定可以选上及判断状态的合法性,令dp中除dp[0]外均为-1,这样也保证了0组中被选中的物品不会被后面组中的物品覆盖,因为0组后的状态dp[i][0]均为-1,已选的物品不能被覆盖;
s=1时最多放一件,取1组中的一件与上一层比较即可;
s=2时就是01背包了,无限制
Time Limit : 2000/1000ms (Java/Other) Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 1 Accepted Submission(s) : 1
Problem Description
Happy New Term!
As having become a junior, xiaoA recognizes that there is not much time for her to AC problems, because there are some other things for her to do, which makes her nearly mad.
What's more, her boss tells her that for some sets of duties, she must choose at least one job to do, but for some sets of things, she can only choose at most one to do, which is meaningless to the boss. And for others, she can do of her will. We just define the things that she can choose as "jobs". A job takes time , and gives xiaoA some points of happiness (which means that she is always willing to do the jobs).So can you choose the best sets of them to give her the maximum points of happiness and also to be a good junior(which means that she should follow the boss's advice)?
Input
There are several test cases, each test case begins with two integers n and T (0<=n,T<=100) , n sets of jobs for you to choose and T minutes for her to do them. Follows are n sets of description, each of which starts with two integers m and s (0<m<=100), there are m jobs in this set , and the set type is s, (0 stands for the sets that should choose at least 1 job to do, 1 for the sets that should choose at most 1 , and 2 for the one you can choose freely).then m pairs of integers ci,gi follows (0<=ci,gi<=100), means the ith job cost ci minutes to finish and gi points of happiness can be gained by finishing it. One job can be done only once.
Output
One line for each test case contains the maximum points of happiness we can choose from all jobs .if she can’t finish what her boss want, just output -1 .
Sample Input
3 3
2 1
2 5
3 8
2 0
1 0
2 1
3 2
4 3
2 1
1 1
3 4
2 1
2 5
3 8
2 0
1 1
2 8
3 2
4 4
2 1
1 1
1 1
1 0
2 1
5 3
2 0
1 0
2 1
2 0
2 2
1 1
2 0
3 2
2 1
2 1
1 5
2 8
3 2
3 8
4 9
5 10
Sample Output
2 3
2 0
1 3
2 8
2 2
1 40
2 80
2 3
2 2
1 40
2 80
2 0
1 3
2 8
2 3
2 0
1 40
2 80
2 0
1 300
2 8
#include<stdio.h>
#include<string.h>
#define size 110
int dp[size][size];
int c[size];
int w[size];
int n,t,m,s;
int max(int a,int b)
{
return a>b?a:b;
}
int main()
{
int i,j,k;
while(scanf("%d %d",&n,&t)!=EOF)
{
memset(dp,-1,sizeof(dp));
memset(dp[0],0,sizeof(dp[0]));
for(i=1;i<=n;i++)
{
scanf("%d %d",&m,&s);
for(j=0;j<m;j++)
{
scanf("%d %d",&c[j],&w[j]);
}
if(s==0)
{
for(k=0;k<m;k++)
{
for(j=t;j>=c[k];j--)
{
if(dp[i][j-c[k]]!=-1)
dp[i][j]=max(dp[i][j],dp[i][j-c[k]]+w[k]);
if(dp[i-1][j-c[k]]!=-1)
dp[i][j]=max(dp[i][j],dp[i-1][j-c[k]]+w[k]);
}
}
}
else if(s==1)
{
for(j=0;j<=t;j++)
dp[i][j]=dp[i-1][j];
for(k=0;k<m;k++)
{
for(j=t;j>=c[k];j--)
{
if(dp[i-1][j-c[k]]!=-1)
dp[i][j]=max(dp[i][j],dp[i-1][j-c[k]]+w[k]);
}
}
}
else
{
for(j=0;j<=t;j++)
dp[i][j]=dp[i-1][j];
for(k=0;k<m;k++)
{
for(j=t;j>=c[k];j--)
{
if(dp[i][j-c[k]]!=-1)
dp[i][j]=max(dp[i][j],dp[i][j-c[k]]+w[k]);
}
}
}
}
printf("%d\n",dp[n][t]);
}
return 0;
}