Pseudoforest
Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1128 Accepted Submission(s): 432
Problem Description
In graph theory, a pseudoforest is an undirected graph in which every connected component has at most one cycle. The maximal pseudoforests of G are the pseudoforest subgraphs of G that are not contained within any larger pseudoforest of G. A pesudoforest is larger than another if and only if the total value of the edges is greater than another one’s.
Input
The input consists of multiple test cases. The first line of each test case contains two integers, n(0 < n <= 10000), m(0 <= m <= 100000), which are the number of the vertexes and the number of the edges. The next m lines, each line consists of three integers, u, v, c, which means there is an edge with value c (0 < c <= 10000) between u and v. You can assume that there are no loop and no multiple edges.
The last test case is followed by a line containing two zeros, which means the end of the input.
Output
Output the sum of the value of the edges of the maximum pesudoforest.
Sample Input
3 3
0 1 1
1 2 1
2 0 1
4 5
0 1 1
1 2 1
2 3 1
3 0 1
0 2 2
0 0
Sample Output
Source
“光庭杯”第五届华中北区程序设计邀请赛 暨 WHU第八届程序设计竞赛
本题没有说图是连通图,故不能求得最大生成树+最大边(不在最大生成树中)
在图的所有连通分支中,每个分支上有最大生成树+最大边(不在最大生成树中)
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
using namespace std;
const int N=10010;
int n,m;
int father[N];
int circle[N];
struct edge
{
int x,y,z;
}e[10*N];
int find(int x)
{
if(x!=father[x])
{
father[x]=find(father[x]);
}
return father[x];
}
int cmp(edge e1,edge e2)
{
return e1.z>e2.z;
}
int Kruskal()
{
int i,j,ans=0;
memset(circle,0,sizeof(circle));
for(i=0;i<m;i++)
{
int x=find(e[i].x);
int y=find(e[i].y);
if(x==y)
{
if(!circle[x])
{
circle[x]=1;
ans+=e[i].z;
}
continue ;
}
if(circle[x]&&circle[y])
continue;
if(circle[x]&&!circle[y])
{
father[y]=x;
}
else
{
father[x]=y;
}
ans+=e[i].z;
}
return ans;
}
int main()
{
int i,j;
while(scanf("%d%d",&n,&m)!=EOF)
{
if(n==0&&m==0) break;
for(i=0;i<n;i++)
{
father[i]=i;
}
for(i=0;i<m;i++)
{
scanf("%d%d%d",&e[i].x,&e[i].y,&e[i].z);
}
sort(e,e+m,cmp);
printf("%d\n",Kruskal());
}
return 0;
}