HDU 1698 Just a Hook(线段树)

Description
对一个初始值都是1的区间[1,n]进行一些区间更新操作,每次将一个区间[a,b]的值更新为c,问更新后的区间和
Input
第一行为一整数T表示用例组数,每组用例第一行为一整数n表示区间大小,第二行为一整数q表示操作数,之后q行每行三个整数a,b,c表示将区间[a,b]的值都更新为c
Output
对于每组用例,输出更新之后的区间和
Sample Input
1
10
2
1 5 2
5 9 3
Sample Output
Case 1: The total value of the hook is 24.
Solution
线段树区间更新+区间查询
Code

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
#define maxn 111111
int t,n,q;
struct Tree
{
    int left,right,data;
}T[4*maxn];
void build(int l,int r,int t)
{
    T[t].left=l;
    T[t].right=r;
    T[t].data=1;
    if(l==r)return ;
    int mid=(l+r)>>1;
    build(l,mid,2*t);
    build(mid+1,r,2*t+1);
}
void push_down(int t)
{
    if(T[t].data!=-1)
    {
        T[2*t].data=T[2*t+1].data=T[t].data;
        T[t].data=-1;
    }
}
void update(int l,int r,int z,int t)
{
    if(T[t].left==l&&T[t].right==r||T[t].data==z)
    {
        T[t].data=z;
        return ;
    }
    push_down(t);
    int mid=(T[t].left+T[t].right)>>1;
    if(r<=mid)update(l,r,z,2*t);
    else if(l>mid)update(l,r,z,2*t+1);
    else
    {
        update(l,mid,z,2*t);
        update(mid+1,r,z,2*t+1);
    }
}
int query(int t)
{
    if(T[t].data!=-1)
        return (T[t].right-T[t].left+1)*T[t].data;
    return query(2*t)+query(2*t+1);
}
int main()
{
    int res=1;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&q);
        build(1,n,1);
        while(q--)
        {
            int a,b,c;
            scanf("%d%d%d",&a,&b,&c);
            update(a,b,c,1);
        }
        int ans=query(1);
        printf("Case %d: The total value of the hook is %d.\n",res++,ans);
    }
    return 0;
}

你可能感兴趣的:(HDU 1698 Just a Hook(线段树))