poj1915(滚动数组队列)

Problem G

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 60000/30000K (Java/Other)
Total Submission(s) : 6   Accepted Submission(s) : 5
Problem Description
Background 
Mr Somurolov, fabulous chess-gamer indeed, asserts that no one else but him can move knights from one position to another so fast. Can you beat him? 
The Problem 
Your task is to write a program to calculate the minimum number of moves needed for a knight to reach one point from another, so that you have the chance to be faster than Somurolov. 
For people not familiar with chess, the possible knight moves are shown in Figure 1. 
poj1915(滚动数组队列)_第1张图片
 

Input
The input begins with the number n of scenarios on a single line by itself. 
Next follow n scenarios. Each scenario consists of three lines containing integer numbers. The first line specifies the length l of a side of the chess board (4 <= l <= 300). The entire board has size l * l. The second and third line contain pair of integers {0, ..., l-1}*{0, ..., l-1} specifying the starting and ending position of the knight on the board. The integers are separated by a single blank. You can assume that the positions are valid positions on the chess board of that scenario.
 

Output
For each scenario of the input you have to calculate the minimal amount of knight moves which are necessary to move from the starting point to the ending point. If starting point and ending point are equal,distance is zero. The distance must be written on a single line.
 

Sample Input
   
   
   
   
3 8 0 0 7 0 100 0 0 30 50 10 1 1 1 1
 

Sample Output
   
   
   
   
5 28 0
 
#include<iostream>
#include<cstdio>
#include<cstring>
#define ZDY 300
#define add_front front=(front+1)%ZDY;
#define add_end end=(end+1)%ZDY;
using namespace std;
const int MAXN=305;
int n,m,sx,sy,ex,ey;
struct node
{
	int x,y,w;
	node(int xx=0,int yy=0,int ww=0)
	{
		x=xx,y=yy,w=ww;
	}
}data[MAXN*MAXN];
bool vis[MAXN][MAXN];
int dx[]={-2,-2,-1,-1,1,1,2,2};
int dy[]={-1,1,-2,2,-2,2,-1,1};

bool is_ill(int x,int y)
{
	return x<0||x>=n||y<0||y>=n ;
}
int bfs()
{
	int i,front=0,end=1;
	data[0]=node(sx,sy,0);
	memset(vis,0,sizeof(vis));
	while(front!=end)
	{
		node e=data[front];
		add_front;
		if(e.x==ex&&e.y==ey)return e.w;
		for(i=0;i<8;i++)
		{
			int curx=e.x+dx[i];
			int cury=e.y+dy[i];
			if(vis[curx][cury]||is_ill(curx,cury))continue;
			data[end]=node(curx,cury,e.w+1);
			add_end;
			vis[curx][cury]=1;
		}
	}
	return -1;
}
int main()
{
	//freopen("123.txt","r",stdin);
	int N;
	cin>>N;
	while(N--)
	{
		scanf("%d",&n);
		scanf("%d%d",&sx,&sy);
		scanf("%d%d",&ex,&ey);
		if(sx==ex&&sy==ey)
		{
			printf("0\n");
			continue;
		}
		printf("%d\n",bfs());
	}
	return 0;
}


你可能感兴趣的:(poj1915(滚动数组队列))