NOJ [1085] kiki's game

  • 问题描述
  • Recently kiki has nothing to do. While she is bored, an idea appears in his mind, she just playes the checkerboard game.The size of the chesserboard is n*m.First of all, a coin is placed in the top right corner(1,m). Each time one people can move the coin into the left, the underneath or the left-underneath blank space.The person who can't make a move will lose the game. kiki plays it with ZZ.The game always starts with kiki. If both play perfectly, who will win the game?
  • 输入
  • Input contains multiple test cases. Each line contains two integer n, m (0<n,m<=2000). The input is terminated when n=0 and m=0.
  • 输出
  • If kiki wins the game printf "Wonderful!", else "What a pity!".
  • 样例输入
  • 5 3
    5 4
    6 6
    0 0
    
  • 样例输出
  • What a pity!
    Wonderful!
    Wonderful!
    
    组合博弈入门题,
    正确找到必败点和必胜点,就不难做出
    #include<stdio.h>
    
    int main()
    {
      int n,m;
      while(~scanf("%d%d",&n,&m) && (n || m))
      {
        if(m%2 && !(n%2))
          printf("Wonderful!\n");
        else if(m%2 && n%2)
          printf("What a pity!\n");
        else
          printf("Wonderful!\n");
      }
      return 0;
    }


你可能感兴趣的:(NOJ [1085] kiki's game)