统计同成绩学生人数
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13735 Accepted Submission(s): 8033
Problem Description
读入N名学生的成绩,将获得某一给定分数的学生人数输出。
Input
测试输入包含若干测试用例,每个测试用例的格式为
第1行:N
第2行:N名学生的成绩,相邻两数字用一个空格间隔。
第3行:给定分数
当读到N=0时输入结束。其中N不超过1000,成绩分数为(包含)0到100之间的一个整数。
Output
对每个测试用例,将获得给定分数的学生人数输出。
Sample Input
3
80 60 90
60
2
85 66
0
5
60 75 90 55 75
75
0
Sample Output
1
0
2
Huge input, scanf is recommended.
Source
浙大计算机研究生复试上机考试-2006年
#include <stdio.h>
#include <string.h>
#define maxn 102
int arr[maxn];
int main()
{
int n, m;
while(scanf("%d", &n), n){
memset(arr, 0, sizeof(arr));
while(n--){
scanf("%d", &m);
++arr[m];
}
scanf("%d", &m);
printf("%d\n", arr[m]);
}
return 0;
}