深搜:A Knight's Journey

A Knight's Journey

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 40   Accepted Submission(s) : 13
Problem Description
深搜:A Knight's Journey_第1张图片 Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?

Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
 

Input
The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .
 

Output
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.
 

Sample Input
   
   
   
   
3 1 1 2 3 4 3
 

Sample Output
   
   
   
   
Scenario #1: A1 Scenario #2: impossible Scenario #3: A1B3C1A2B4C2A3B1C3A4B2C4


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <string>
#define Max 30

using namespace std;

int p,q;
int visit[Max][Max];
int dir[8][2]={{-1,-2},{1,-2},{-2,-1},{2,-1},{-2,1},{2,1},{-1,2},{1,2}};

int dfs(int x,int y,int step,string ans){
    if(step==p*q){
        cout<<ans<<endl<<endl;
        return 1;
    }
    else{
        for(int i=0;i<8;i++){
            int x1=x+dir[i][0];
            int y1=y+dir[i][1];
            char ans1=y1+'A';
            char ans2=x1+'1';
            if(x1>=0&&y1>=0&&x1<p&&y1<q&&visit[x1][y1]==0){
                visit[x1][y1]=1;
                if(dfs(x1,y1,step+1,ans+ans1+ans2))
                    return 1;
                visit[x1][y1]=0;
            }
        }
        return 0;
    }
}

int main(){
    int n,no=0;
    cin>>n;
    while(n--){
        no++;
        memset(visit,0,sizeof(visit));
        visit[0][0]=1;
        cin>>p>>q;
        cout<<"Scenario #"<<no<<":"<<endl;
        if(dfs(0,0,1,"A1")==0)
            cout<<"impossible"<<endl<<endl;
    }
    return 0;
}


你可能感兴趣的:(Integer,input,Path,each,output,Numbers)