GCC 超时

1、http://acm.sdut.edu.cn/sdutoj/showproblem.php?pid=1919&cid=1199

2、GCC

Time Limit: 1000MS    Memory limit: 65536K

题目描述

The GNU Compiler Collection (usually shortened to GCC) is a compiler system produced by the GNU Project supporting various programming languages.  But it doesn’t contains the math operator “!”.

In mathematics the symbol represents the factorial operation. The expression n! means "the product of the integers from 1 to n". For example, 4! (read four factorial) is 4 × 3 × 2 × 1 = 24. (0! is defined as 1, which is a neutral element in multiplication, not multiplied by anything.)

We want you to help us with this formation: (0! + 1! + 2! + 3! + 4! + ... + n!)%m.

输入

The first line consists of an integer T, indicating the number of test cases.

Each test on a single consists of two integer n and m.

0 < T <= 20
0 <= n < 10 100 (without leading zero)
0 < m < 1000000

输出

Output the answer of (0! + 1! + 2! + 3! + 4! + ... + n!)%m.

示例输入

1 10 861017 

示例输出

593846

 

3、超时代码:

#include<stdio.h>
#include<string.h>
int dp[1000005];
int jie(int n)
{
    int ans=1;
    if(dp[n]!=0)
    return dp[n];
    for(int i=n;i>=1;i--)
    {
        if(dp[i]!=0)
        {
            ans*=dp[i];
            break;
        }
        else
        ans*=i;
    }
    return ans;
}
int main()
{
    int t,n,m;
    scanf("%d",&t);
    memset(dp,0,sizeof(dp));
    for(int i=0;i<t;i++)
    {
        long long sum=0;
        scanf("%d%d",&n,&m);
        if(n>m)
        n=m-1;
        for(int j=0;j<=n;j++)
        {
            dp[j]=jie(j);
            sum+=dp[j]%m;
        }
        printf("%lld\n",sum%m);
    }
    return 0;
}


 

你可能感兴趣的:(GCC 超时)