南邮 OJ 1380 Tetrahedral Stacks of Cannonballs

Tetrahedral Stacks of Cannonballs

时间限制(普通/Java) :  1000 MS/ 3000 MS          运行内存限制 : 65536 KByte
总提交 : 44            测试通过 : 33 

比赛描述

    

WALL.ETM, as he cleans up and organizes the depopulated Earth, has come upon some Civil War memorials. He is consolidating the cannonballs into one location, and decides to use pyramids with triangular bases rather than ones with square bases.

In Civil War memorials with cannons and stacks of cannonballs, the cannonballs were sometimes stacked as a four-sided pyramid, with the base as a square of cannonballs with n balls on each side. An alternative is to stack them in a three-sided pyramid, which is in fact one of the Platonic solids, a tetrahedron.

This tetrahedron of cannonballs has a base that is an equilateral triangle of cannonballs with n balls on each side. The number of balls in that triangle is given simply by adding together the numbers from 1 to n. On top of each layer (starting from the base) is a triangle with one less ball on each side, up to the top-most layer with a single ball.

Given the number of cannonballs on each side of the base, compute the total number of cannonballs in the entire tetrahedral stack.




输入

The first line contains a single number n, giving the number of tetrahedral problems posed, for a maximum of 100 problems. Following that are exactly n lines, each with a single number giving the number of cannonballs on each side of the base for a tetrahedron of cannonballs, a number greater than 0 and less than 1000.

输出

For each problem, output the problem number (starting from 1), a colon and a blank, the number of cannonballs on each side of the base, one blank, and finally the total number of cannonballs in the tetrahedron.

样例输入

6
1
2
3
5
27
999

样例输出

1: 1 1
2: 2 4
3: 3 10
4: 5 35
5: 27 3654
6: 999 166666500

提示

undefined

题目来源

2008 ACM-ICPC Pacific Northwest Region



#include<iostream>
#define MAX_N 1001
int a[MAX_N];

int main(){
	int cas,ca,i;
	for(i=1;i<MAX_N;i++){
		a[i] = i;
	}
	for(ca=0;ca<2;ca++){
		for(i=0;i<MAX_N;i++){
			a[i] = a[i-1]+a[i];
		}
	}
	scanf("%d",&cas);
	for(ca=1;ca<=cas;ca++){
		scanf("%d",&i);
		printf("%d: %d %d\n",ca,i,a[i]);
	}
}







你可能感兴趣的:(ACM,stacks,南邮OJ,Tetrahedral)