HDOJ 1796 How many integers can you find 容斥原理



How many integers can you find

Time Limit: 12000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4852    Accepted Submission(s): 1389


Problem Description
  Now you get a number N, and a M-integers set, you should find out how many integers which are small than N, that they can divided exactly by any integers in the set. For example, N=12, and M-integer set is {2,3}, so there is another set {2,3,4,6,8,9,10}, all the integers of the set can be divided exactly by 2 or 3. As a result, you just output the number 7.
 

Input
  There are a lot of cases. For each case, the first line contains two integers N and M. The follow line contains the M integers, and all of them are different from each other. 0<N<2^31,0<M<=10, and the M integer are non-negative and won’t exceed 20.
 

Output
  For each case, output the number.
 

Sample Input
   
   
   
   
12 2 2 3
 

Sample Output
   
   
   
   
7
 

Author
wangye
 

Source
2008 “Insigma International Cup” Zhejiang Collegiate Programming Contest - Warm Up(4)
 



/* ***********************************************
Author        :CKboss
Created Time  :2015年03月27日 星期五 16时11分03秒
File Name     :HDOJ1796.cpp
************************************************ */

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <string>
#include <cmath>
#include <cstdlib>
#include <vector>
#include <queue>
#include <set>
#include <map>

using namespace std;

int n,m;
vector<int> vi;

int RET;

int gcd(int a,int b)
{
	if(b==0) return a;
	return gcd(b,a%b);
}

int lcm(int a,int b)
{
	return a/gcd(a,b)*b;
}

int N;

void dfs(int x,int mark,int L)
{
	for(int i=x;i<m;i++)
	{
		int nl=lcm(L,vi[i]);
		RET+=mark*N/nl;
		dfs(i+1,-mark,nl);
	}
}

int main()
{
    //freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdout);
	
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		vi.clear();
		for(int i=0;i<m;i++)
		{
			int x; scanf("%d",&x);
			if(x) vi.push_back(x);
		}
		N=n-1; RET=0; dfs(0,1,1);
		printf("%d\n",RET);
	}
    
    return 0;
}





你可能感兴趣的:(HDOJ 1796 How many integers can you find 容斥原理)