HDU 2063 过山车 二分法 匈牙利裸题

B - 过山车
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
Submit  Status

Description

RPG girls今天和大家一起去游乐场玩,终于可以坐上梦寐以求的过山车了。可是,过山车的每一排只有两个座位,而且还有条不成文的规矩,就是每个女生必须找个个男生做partner和她同坐。但是,每个女孩都有各自的想法,举个例子把,Rabbit只愿意和XHD或PQK做partner,Grass只愿意和linle或LL做partner,PrincessSnow愿意和水域浪子或伪酷儿做partner。考虑到经费问题,boss刘决定只让找到partner的人去坐过山车,其他的人,嘿嘿,就站在下面看着吧。聪明的Acmer,你可以帮忙算算最多有多少对组合可以坐上过山车吗?
 

Input

输入数据的第一行是三个整数K , M , N,分别表示可能的组合数目,女生的人数,男生的人数。0<K<=1000 
1<=N 和M<=500.接下来的K行,每行有两个数,分别表示女生Ai愿意和男生Bj做partner。最后一个0结束输入。
 

Output

对于每组数据,输出一个整数,表示可以坐上过山车的最多组合数。
 

Sample Input

        
        
        
        
6 3 3 1 1 1 2 1 3 2 1 2 3 3 1 0
 

Sample Output

        
        
        
        
3
 
ACcode:
#pragma warning(disable:4786)//使命名长度不受限制
#pragma comment(linker, "/STACK:102400000,102400000")//手工开栈
#include <map>
#include <set>
#include <queue>
#include <cmath>
#include <stack>
#include <cctype>
#include <cstdio>
#include <cstring>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#define rd(x) scanf("%d",&x)
#define rd2(x,y) scanf("%d%d",&x,&y)
#define rds(x) scanf("%s",x)
#define rdc(x) scanf("%c",&x)
#define ll long long int
#define maxn 505
#define mod 1000000007
#define INF 0x3f3f3f3f //int 最大值
#define FOR(i,f_start,f_end) for(int i=f_start;i<=f_end;++i)
#define MT(x,i) memset(x,i,sizeof(x))
#define PI  acos(-1.0)
#define E  exp(1)
using namespace std;
bool bmap[maxn][maxn];
bool bmask[maxn];
int nx,ny;
int cx[maxn];
int findpath(int u){
    FOR(i,1,ny)
        if(bmap[u][i]&&!bmask[i]){
            bmask[i]=1;
            if(cx[i]==-1||findpath(cx[i])){
                cx[i]=u;
                return 1;
            }
        }
    return 0;
}
int MaxMatch(){
    int res=0;
    FOR(i,1,nx){
            MT(bmask,false);
            res+=findpath(i);
        }
    return res;
}
int main(){
    int k,x,y;
    while(rd(k)&&k){
        rd2(nx,ny);
        MT(bmap,false);
        MT(bmask,false);
        MT(cx,0);
        MT(cx,-1);
        FOR(i,1,k){
            rd2(x,y);
            bmap[x][y]=1;
        }
        printf("%d\n",MaxMatch());
    }
}
/*
6 3 3
1 1
1 2
1 3
2 1
2 3
3 1
0
*/


你可能感兴趣的:(C++,HDU,二分图)