uvaoj1585oxooxx得分问题

/*There is an objective test result such as ``OOXXOXXOOO". An `O' means a correct answer of a problem and an `X' means a wrong answer. The score of each problem of this test is calculated by itself and its just previous consecutive `O's only when the answer is correct. For example, the score of the 10th problem is 3 that is obtained by itself and its two previous consecutive `O's.

Therefore, the score of ``OOXXOXXOOO" is 10 which is calculated by ``1+2+0+0+1+0+0+1+2+3".

You are to write a program calculating the scores of test results.

Input 

Your program is to read from standard input. The input consists of T test cases. The number of test cases T is given in the first line of the input. Each test case starts with a line containing a string composed by `O' and `X' and the length of the string is more than 0 and less than 80. There is no spaces between `O' and `X'.

Output 

Your program is to write to standard output. Print exactly one line for each test case. The line is to contain the score of the test case.

The following shows sample input and output for five test cases.

Sample Input 

5 
OOXXOXXOOO 
OOXXOOXXOO 
OXOXOXOXOXOXOX 
OOOOOOOOOO 
OOOOXOOOOXOOOOX
Sample Output 

10 
9 
7 
55 
30


*/


#include<stdio.h>
int main()
{
	int n,p=1,s=0,first=1;//用first,因为4的末尾也有换行符,避免输出0;所以用了first,还加了一次循环。 或者用周天猫说的直接再getchar一次即可。 
	char c;
	scanf("%d",&n);
	for(int i=1;i<=n+1;i++)
	{
		s=0,p=1;
		while((c=getchar())!='\n')   //     包括第一行4有有一个换行符。
		{							//		用scanf("%s")也可 解决这个问题,因为末尾的|n。。scanf系统会自动认为是键入完的标志,会改成\0。所以循环条件改为\0标志即可。 
			//printf("%c ",c);
			if(c=='O')
			{
			
				s+=p;
				++p;
				
			}
			else if(c=='X')p=1;
		}
		if(first) first=0;
		else printf("%d\n",s);
	}
	return 0;
} 

你可能感兴趣的:(uvaoj1585oxooxx得分问题)