POJ 2437:Muddy roads 【贪心】

Muddy roads
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 2814   Accepted: 1317

Description

Farmer John has a problem: the dirt road from his farm to town has suffered in the recent rainstorms and now contains (1 <= N <= 10,000) mud pools. 

Farmer John has a collection of wooden planks of length L that he can use to bridge these mud pools. He can overlap planks and the ends do not need to be anchored on the ground. However, he must cover each pool completely. 

Given the mud pools, help FJ figure out the minimum number of planks he needs in order to completely cover all the mud pools.

Input

* Line 1: Two space-separated integers: N and L 

* Lines 2..N+1: Line i+1 contains two space-separated integers: s_i and e_i (0 <= s_i < e_i <= 1,000,000,000) that specify the start and end points of a mud pool along the road. The mud pools will not overlap. These numbers specify points, so a mud pool from 35 to 39 can be covered by a single board of length 4. Mud pools at (3,6) and (6,9) are not considered to overlap. 

Output

* Line 1: The miminum number of planks FJ needs to use.

Sample Input

3 3
1 6
13 17
8 12

Sample Output

5

Hint

INPUT DETAILS: 

FJ needs to use planks of length 3 to cover 3 mud pools. The mud pools cover regions 1 to 6, 8 to 12, and 13 to 17. 

OUTPUT DETAILS: 

FJ can cover the mud pools with five planks of length 3 in the following way: 
                   111222..333444555....

                   .MMMMM..MMMM.MMMM....

                   012345678901234567890
又学了一个函数,ceil,对浮点数上限取整~~
AC-code:
#include<cstdio>
#include<algorithm>
#include<cmath>
using namespace std;
struct node
{
	int st,en;
}s[10005];
bool cmp(node a,node b)
{
	return a.st<b.st;
}
int main()
{
	int n,l,i,flag,num,ans;
	scanf("%d%d",&n,&l);
	for(i=0;i<n;i++)
		scanf("%d%d",&s[i].st,&s[i].en);
	sort(s,s+n,cmp);
	flag=0;ans=0;
	for(i=0;i<n;i++)
	{
		if(flag>s[i].en)
		{
			continue;
		}
		else if(flag>s[i].st)
		{
			num=ceil((s[i].en-flag)*1.0/l);
			flag+=num*l;
			ans+=num;
		}
		else
		{
			num=ceil((s[i].en-s[i].st)*1.0/l);
			flag=s[i].st+num*l;
			ans+=num;
		}
	}
	printf("%d\n",ans);
	return 0;
 } 


你可能感兴趣的:(POJ 2437:Muddy roads 【贪心】)