UVAOJ133The Dole Queue

/* The Dole Queue 

In a serious attempt to downsize (reduce) the dole queue, The New National Green Labour Rhinoceros Party has decided on the following strategy. Every day all dole applicants will be placed in a large circle, facing inwards. Someone is arbitrarily chosen as number 1, and the rest are numbered counter-clockwise up to N (who will be standing on 1's left). Starting from 1 and moving counter-clockwise, one labour official counts off k applicants, while another official starts from N and moves clockwise, counting m applicants. The two who are chosen are then sent off for retraining; if both officials pick the same person she (he) is sent off to become a politician. Each official then starts counting again at the next available person and the process continues until no-one is left. Note that the two victims (sorry, trainees) leave the ring simultaneously, so it is possible for one official to count a person already selected by the other official.

Input

Write a program that will successively read in (in that order) the three numbers (N, k and m; k, m > 0, 0 < N < 20) and determine the order in which the applicants are sent off for retraining. Each set of three numbers will be on a separate line and the end of data will be signalled by three zeroes (0 0 0).

Output

For each triplet, output a single line of numbers specifying the order in which people are chosen. Each number should be in a field of 3 characters. For pairs of numbers list the person chosen by the counter-clockwise official first. Separate successive pairs (or singletons) by commas (but there should not be a trailing comma).

Sample input

10 4 3
0 0 0
Sample output

 tex2html_wrap_inline34 4 tex2html_wrap_inline34 8, tex2html_wrap_inline34 9 tex2html_wrap_inline34 5, tex2html_wrap_inline34 3 tex2html_wrap_inline34 1, tex2html_wrap_inline34 2 tex2html_wrap_inline34 6, tex2html_wrap_inline50 10, tex2html_wrap_inline34 7

where  tex2html_wrap_inline50 represents a space.*/ 


#include<stdio.h>
#include<math.h>
#include<string.h>
int main()
{
    int n,k,m,CNT=0,i0=0,j0=0,a,b,i,j,flaga,flagb,cnta=0,cntb=0,first=1;
    int ppel[20];

    while(scanf("%d%d%d",&n,&k,&m)==3&&n)
    {
    CNT=0;
    memset(ppel,0,sizeof(ppel));
    for(i=0;i<n;i++){ppel[i]=i+1;}
    first=1;j0=i0=0;
    while(1)
    {
        a=b=-1;
        flaga=flagb=1;
        cnta=cntb=0;
        for(i=i0;;i++)
        {
            if(ppel[i%n]!=0) cnta++;
            if(cnta%k==0&&cnta!=0)
            {
                a=ppel[i%n];
                flaga=0;
            }
            if(!flaga) {i0=i+1;break;}
        }
        for(j=j0;;j++)
        {
            if(j>n-1) j=0;
            if(ppel[(n-1-j)%n]!=0) cntb++;
            if(cntb%m==0&&cntb!=0)
            {
                b=ppel[(n-1-j)%20];
                flagb=0;
            }
            if(!flagb){j0=j+1;break;}
        }
        if(first)
        {
            if(a==b)
            {printf("%3d",a);CNT++;}
            else {printf("%3d%3d",a,b);CNT+=2;}
            first=0;
        }
        else
        {
            if(a==b) {printf(",%3d",a);CNT++;}
            else {printf(",%3d%3d",a,b);CNT+=2;}
        }
        ppel[i%n]=0; ppel[(n-1-j)%20]=0;
        if(CNT==n) break;
    }
    putchar('\n');
    }
   // putchar('\n');
    return 0;

}
//  一开始老wa,不知道为什么,后来用正确的程序在cmd与它对比才发现多输出了末尾的一行空行。 而且我的方法比较不简洁,也没把顺时针逆时针统一成一个式子。

入门经典标准答案:
#include<stdio.h>
#define maxn 25
int n,k,m;
int a[25];
int go(int p,int d,int t)
{
	while(t--){
		do{p=(p+d+n-1)%n+1;	} while(a[p]==0);
		
	}
	return p;
}

int main()
{ 
	while(scanf("%d%d%d",&n,&k,&m)==3&&n)
	{
		for(int i=1;i<=n;i++) a[i]=i;
		int left=n;
		int p1=n,p2=1;
		while(left)
		{
			p1=go(p1,1,k);
			p2=go(p2,-1,m);
			printf("%3d",p1);left--;
			if(p2!=p1){printf("%3d",p2);left--;
			}
			a[p1]=a[p2]=0;
			if(left) printf(",");
		}
		printf("\n");
	}
	return 0;
}

 /*有三点值得学习:
  1.用了外部函数引用方便,使代码简洁。
  2.用了一个式子把顺时针逆时针统一了起来。 
  3.用了数组a[1],a[2]...到a[n]来代替环,时后面的逻辑更易懂,而不像我写的用a[0],..,a[n-1]代替环。
  4.用 数组a[1],a[2]...到a[n]来代替环的余数除法有小技巧。
  为了体现3,4两点的优点和区别我又改写成下面的代码,同样ac:
  */
  
#include<stdio.h>
#define maxn 25
int n,k,m;
int a[25];
int go(int p,int d,int t)
{
	while(t--){
		do{p=(p+d+n)%n;	} while(a[p]==0);
		
	}
	return p;
}

int main()
{ 
	while(scanf("%d%d%d",&n,&k,&m)==3&&n)
	{
		for(int i=0;i<n;i++) a[i]=i+1;
	//	for(int i=0;i<10;i++) printf("%d",a[i]);
		int left=n;
		int p1=n-1,p2=0;
		while(left)
		{
			p1=go(p1,1,k);
			p2=go(p2,-1,m);
			printf("%3d",a[p1]);left--;
			if(p2!=p1){printf("%3d",a[p2]);left--;
			}
			a[p1]=a[p2]=0;
			if(left) printf(",");
		}
		printf("\n");
	}
	return 0;
} 
//把入门经典 改成了 用a[0],..,a[n-1]代替环。统一顺逆的式子也需要改变。从而相形见绌、 

你可能感兴趣的:(UVAOJ133The Dole Queue)