HDU 2952 Counting Sheep 简单dfs

Counting Sheep

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2657    Accepted Submission(s): 1763


Problem Description
A while ago I had trouble sleeping. I used to lie awake, staring at the ceiling, for hours and hours. Then one day my grandmother suggested I tried counting sheep after I'd gone to bed. As always when my grandmother suggests things, I decided to try it out. The only problem was, there were no sheep around to be counted when I went to bed.
HDU 2952 Counting Sheep 简单dfs_第1张图片

Creative as I am, that wasn't going to stop me. I sat down and wrote a computer program that made a grid of characters, where # represents a sheep, while . is grass (or whatever you like, just not sheep). To make the counting a little more interesting, I also decided I wanted to count flocks of sheep instead of single sheep. Two sheep are in the same flock if they share a common side (up, down, right or left). Also, if sheep A is in the same flock as sheep B, and sheep B is in the same flock as sheep C, then sheeps A and C are in the same flock.


Now, I've got a new problem. Though counting these sheep actually helps me fall asleep, I find that it is extremely boring. To solve this, I've decided I need another computer program that does the counting for me. Then I'll be able to just start both these programs before I go to bed, and I'll sleep tight until the morning without any disturbances. I need you to write this program for me.
 

Input
The first line of input contains a single number T, the number of test cases to follow.

Each test case begins with a line containing two numbers, H and W, the height and width of the sheep grid. Then follows H lines, each containing W characters (either # or .), describing that part of the grid.
 

Output
For each test case, output a line containing a single number, the amount of sheep flock son that grid according to the rules stated in the problem description.

Notes and Constraints
0 < T <= 100
0 < H,W <= 100
 

Sample Input
   
   
   
   
2 4 4 #.#. .#.# #.## .#.# 3 5 ###.# ..#.. #.###
 

Sample Output
   
   
   
   
6 3
 

Source
IDI Open 2009
 

Recommend
gaojie   |   We have carefully selected several similar problems for you:   1016  1010  1241  1258  1181 
 


ACcode:

#pragma warning(disable:4786)//使命名长度不受限制
#pragma comment(linker, "/STACK:102400000,102400000")//手工开栈
#include <map>
#include <set>
#include <queue>
#include <cmath>
#include <stack>
#include <cctype>
#include <cstdio>
#include <cstring>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#define rd(x) scanf("%d",&x)
#define rd2(x,y) scanf("%d%d",&x,&y)
#define rds(x) scanf("%s",x)
#define rdc(x) scanf("%c",&x)
#define ll long long int
#define maxn 1005
#define mod 1000000007
#define INF 0x3f3f3f3f //int 最大值
#define FOR(i,f_start,f_end) for(int i=f_start;i<=f_end;++i)
#define MT(x,i) memset(x,i,sizeof(x))
#define PI  acos(-1.0)
#define E  exp(1)
using namespace std;
char a[maxn][maxn];
int tu[4][2]={{1,0},{0,-1},{-1,0},{0,1}};
int loop,n,m,cnt;
void dfs(int x,int y){
    a[x][y]='.';
    FOR(i,0,3){
        int dx=x-tu[i][0];
        int dy=y-tu[i][1];
        if(dx>=0&&dy>=0&&dx<n&&dy<m&&a[dx][dy]=='#')
        dfs(dx,dy);
    }
}
int main(){
    rd(loop);
    while(loop--){
        rd2(n,m);
        FOR(i,0,n-1)rds(a[i]);
        cnt=0;
        FOR(i,0,n-1)
            FOR(j,0,m-1)
                if(a[i][j]=='#'){
                    dfs(i,j);
                    cnt++;

       /* printf("\n\n-------------------------\n\n");
        FOR(i,0,n-1)cout<<a[i]<<'\12';*/
            }
        printf("%d\n",cnt);
    }
    return 0;
}
/*
2
4 4
#.#.
.#.#
#.##
.#.#
3 5
###.#
..#..
#.###
*/

你可能感兴趣的:(C++,HDU,DFS)