HDOJ题目地址:传送门
Wooden Sticks
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17453 Accepted Submission(s): 7121
Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:
(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup.
You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
Output
The output should contain the minimum setup time in minutes, one per line.
Sample Input
3
5
4 9 5 2 2 1 3 5 1 4
3
2 2 1 1 2 2
3
1 3 2 2 3 1
Sample Output
题意:一个机器生产木头,最开始要一分钟,如果下一个木头比上一个木头短和轻,就需要一分钟的时间调试机器,
如果比上一个长和重就不需要时间调试,求最后的最短时间。
解题:
贪心+递减子序列(严格来说是非递增子序列)。按长度从大到小排序,长度相同,按重量从大到小排序。多次寻找递减子序列,即每次都把这一个序列的木头处理掉,即启动时间+1,并把被处理掉的木头做上标记。用一个变量记录被处理掉木头的个数,多次寻找子序列,处理掉木头,当该变量的个数等于木头总数时,退出循环。
比如第一个测试数据
4 9 5 2 2 1 3 5 14
排序后,为了方便看,我们竖着写。排序后:
l w
5 2
4 9
3 5
2 1
1 4
有两个递减子序列:
5 2 2 1
4 9 3 5 1 4
#include<iostream>
#include<stdio.h>
#include<memory.h>
#include<algorithm>
using namespace std;
struct Node{
int length,weight;
int ok;//用来标记木头是否被处理过
}result[5010];
/**
sort排序函数
*/
bool cmp(Node a,Node b){
if(a.length>b.length){
return true;
}else if(a.length==b.length){
if(a.weight>b.weight)
return true;
return false;
}
return false;
}
int main(){
int n,m,i,index;
cin>>n;
while(n--){
cin>>m;
//录入木头的长度和重量
for(i=0;i<m;i++){
cin>>result[i].length>>result[i].weight;
result[i].ok=0;
}
//排序
sort(result,result+m,cmp);
int sum=0;int index=0;//已经被处理的木头的个数
Node temp;
while(1){
if(index==m)//当所有的木头都被处理时,结束循环
break;
//每次启动的时候都要寻找最长最终的木头
for(int i=0;i<m;i++){
if(!result[i].ok){
temp=result[i];
break;//别忘了这一句
}
}
for(int i=0;i<m;i++){
//前提是该木头没有被处理,所以必须加上!wood[i].ok
if(!result[i].ok&&result[i].length<=temp.length&&result[i].weight<=temp.weight){
result[i].ok=1;//该木头被处理
index++;
temp=result[i];//及时更换长度最长,重量最重的那根木头,及递减子序列的当前元素的下一个元素。
}
}
sum++;//一次启动处理结束。
}
printf("%d\n",sum);
}
}
参考博客:传送门