题目链接
http://acm.hdu.edu.cn/showproblem.php?pid=5389
Zero Escape
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 403 Accepted Submission(s): 187
Problem Description
Zero Escape, is a visual novel adventure video game directed by Kotaro Uchikoshi (you may hear about ever17?) and developed by Chunsoft.
Stilwell is enjoying the first chapter of this series, and in this chapter digital root is an important factor.
This is the definition of digital root on Wikipedia:
The digital root of a non-negative integer is the single digit value obtained by an iterative process of summing digits, on each iteration using the result from the previous iteration to compute a digit sum. The process continues until a single-digit number is reached.
For example, the digital root of
65536 is
7 , because
6+5+5+3+6=25 and
2+5=7 .
In the game, every player has a special identifier. Maybe two players have the same identifier, but they are different players. If a group of players want to get into a door numbered
X(1≤X≤9) , the digital root of their identifier sum must be
X .
For example, players
{1,2,6} can get into the door
9 , but players
{2,3,3} can't.
There is two doors, numbered
A and
B . Maybe
A=B , but they are two different door.
And there is
n players, everyone must get into one of these two doors. Some players will get into the door
A , and others will get into the door
B .
For example:
players are
{1,2,6} ,
A=9 ,
B=1
There is only one way to distribute the players: all players get into the door
9 . Because there is no player to get into the door
1 , the digital root limit of this door will be ignored.
Given the identifier of every player, please calculate how many kinds of methods are there,
mod 258280327 .
Input
The first line of the input contains a single number
T , the number of test cases.
For each test case, the first line contains three integers
n ,
A and
B .
Next line contains
n integers
idi , describing the identifier of every player.
T≤100 ,
n≤105 ,
∑n≤106 ,
1≤A,B,idi≤9
Output
For each test case, output a single integer in a single line, the number of ways that these
n players can get into these two doors.
Sample Input
4
3 9 1
1 2 6
3 9 1
2 3 3
5 2 3
1 1 1 1 1
9 9 9
1 2 3 4 5 6 7 8 9
Sample Output
这是一道DP,dp[i][j]代表的是在人数有i个的时候,房间里有j个人的状态有多少种可能。这里可以用滚动数组来记录dp[i][j],可以节省空间。
AC代码
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<set>
#include<map>
#include<vector>
#define rep(i,j,k) for(int i=(int)j;i<=(int)k;i++)
#define per(i,j,k) for(int i=(int)j;i>=(int)k;i--)
using namespace std;
#define mod 258280327
#define N 100010
int dp[2][10];
int k[N];
int main()
{
int t;
scanf("%d",&t);
int n,a,b,sum;
while(t--){
sum=0;
scanf("%d%d%d",&n,&a,&b);
a=a%9;
b=b%9;
for(int i=1;i<=n;i++)
{
scanf("%d",&k[i]);
sum+=k[i];
sum=sum%9;
}
// printf("%d\n",sum);
memset(dp,0,sizeof(dp));
dp[0][0]=1;
int now=0;
for(int i=1;i<=n;i++){
now^=1;
for(int j=0;j<=8;j++) dp[now][j]=0;
for(int j=0;j<=8;j++){
dp[now][(k[i]+j)%9]+=dp[now^1][j];
dp[now][(k[i]+j)%9]=dp[now][(k[i]+j)%9]%mod;
dp[now][j]+=dp[now^1][j];
dp[now][j]=dp[now][j]%mod;
}
}
/*for(int i=0;i<=8;i++) printf("%d ",dp[now][i]);
printf("\n");*/
/* printf("%d %d %d %d\n",dp[now][a],a,b,sum);*/
int ans=dp[now][a]*(((a+b)%9)==sum);
// printf("%d\n",ans);
if(sum==a&&b!=0) ans=(ans+1)%mod;
if(sum==b&&a!=0) ans=(ans+1)%mod;
printf("%d\n",ans);
}
}