对应HDU题目:点击打开链接
Billboard
Time Limit: 20000/8000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11523 Accepted Submission(s): 5077
Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.
On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.
Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.
When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.
If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).
Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
Input
There are multiple cases (no more than 40 cases).
The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.
Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.
Sample Input
Sample Output
题意:(别人的~我懒得写)
在大学门口,有一个高位h 宽为w的广告牌,现在广告牌是空的,有一些小的广告要张贴到广告牌上,已知这些小广告的高度都是1,宽为wi,张贴有一定规律,按照顺序来,并且往最高处贴,如果最高处贴不开就往下一行贴,输出每一张广告贴在的行,若果广告牌上贴不开,就输出-1
思路:
将展板90度旋转,即可将长度作为叶子节点,要注意一点:h的范围很大,而题目最多有n次询问!故答案要么是-1,要么不超过n,所以线段数维护的范围是1~min(h,n);
#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<map>
#include<queue>
#include<stack>
#include<vector>
#include<algorithm>
#include<cstring>
#include<string>
#include<iostream>
const int MAXN=200005*3;//这个我不知道怎样算的,一直试到没有RE,求方法。。。
#define ms(x,y) memset(x,y,sizeof(x))
using namespace std;
int maxn[MAXN];
int ans;
int h,w,n;
void buildtree(int rt, int left, int right)
{
if(left==right){
maxn[rt]=w;
return;
}
int mid=(left+right)>>1;
buildtree(rt<<1, left, mid);
buildtree(rt<<1|1, mid+1, right);
maxn[rt]=max(maxn[rt<<1], maxn[rt<<1|1]);//取叶子结点大的值
}
void updata(int rt, int left, int right, int l)
{
if(left==right){
ans=left;//找到结果!
maxn[rt]-=l;//更新长度
return;
}
int mid=(left+right)>>1;
if(maxn[rt<<1] >= l) updata(rt<<1, left, mid, l);//先往左走(尽量靠前嘛)
else updata(rt<<1|1, mid+1, right, l);//左边不满足则往右走
maxn[rt]=max(maxn[rt<<1], maxn[rt<<1|1]);//更新最值
}
int main()
{
#if 0
freopen("in.txt","r",stdin);
#endif
while(scanf("%d%d%d", &h,&w,&n)==3)
{
int R=min(h,n);//高度最多取到n,故取小的值就可以了
buildtree(1,1,R);
while(n--)
{
int l;
scanf("%d", &l);
if(maxn[1]<l){//如果第一个结点都不满足,就不用算了
printf("-1\n");
continue;
}
updata(1,1,R,l);
printf("%d\n", ans);
}
}
return 0;
}