1408111855-hd-Wooden Sticks.cpp

                                     Wooden Sticks

                                               Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
                                                              Total Submission(s): 11664    Accepted Submission(s): 4828


Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:

(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup.

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
 

Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
 

Output
The output should contain the minimum setup time in minutes, one per line.
 

Sample Input
   
   
   
   
3 5 4 9 5 2 2 1 3 5 1 4 3 2 2 1 1 2 2 3 1 3 2 2 3 1
 

Sample Output
   
   
   
   
2 1 3
 

题目大意

      有一堆木头要进行加工,他们的长度和宽度都不相同,在进行加工的时候,若下一根木头的长度和宽度都不小于此时的木头,则机器不用调整,反之则需要调整机器,每一次调整需要一分钟,要求最短时间。

错误原因

       没理解清除题意,哎,,,,英语是硬伤啊!

解题思路

       要求最短时间明显需要贪心算法,先对长度和宽度做升序排列,然后开始比较,但是需要记住一点,这是求一个最长递增序列,所以每次比较的都是前一跟木头的长度和宽度,所以这题需要再定义一个动态的变量nowl,noww来记录每次比较之后的长度和宽度,所以这题也用到了动态规划。

代码

#include<stdio.h>
#include<algorithm>
using namespace std;
struct wooden
{
    int l,w;
}wd[5100];
bool cmp(wooden a,wooden b)
{
    if(a.l!=b.l)
        return a.l<b.l;
    else
        return a.w<b.w;
}
int main()
{
    int t;
    int n;
    int i,j,nowl,noww,sum;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(i=0;i<n;i++)
            scanf("%d%d",&wd[i].l,&wd[i].w);
        sort(wd,wd+n,cmp);
        sum=0;
        for(i=0;i<n;i++)
        {
            if(wd[i].l!=-1&&wd[i].w!=-1)
            {
                nowl=wd[i].l;
                noww=wd[i].w;
                sum++;
                for(j=i+1;j<n;j++)
                {
                    if(nowl<=wd[j].l&&noww<=wd[j].w)
                    {
                        nowl=wd[j].l;
                        noww=wd[j].w;
                        wd[j].l=-1;
                        wd[j].w=-1;
                    }
                }
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}



 

你可能感兴趣的:(1408111855-hd-Wooden Sticks.cpp)