HDOJ 1087 Super Jumping! Jumping! Jumping!(DP)

Super Jumping! Jumping! Jumping!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 30106    Accepted Submission(s): 13480


Problem Description
Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.



The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.
 

Input
Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.
 

Output
For each case, print the maximum according to rules, and one line one case.
 

Sample Input
   
   
   
   
3 1 3 2 4 1 2 3 4 4 3 3 2 1 0
 

Sample Output
   
   
   
   
4 10 3
 

题意:有n个数字,下一个要选择的数字必须大于前面一个选择的数字,问能等到的最大数字和是多大?

题解:注意啊,不是LIS求和问题啊,是求最大递增子段和,和前几天cf的题一样,不过这里简单很多。

代码如下:


#include<cstdio>
#include<cstring>
#define maxn 1010
#include<algorithm>
#define INF 0x3f3f3f
using namespace std;
int a[1010],dp[1010];
int main()
{
	int n,i,j,ans;
	while(scanf("%d",&n)&&n)
	{
		for(i=1;i<=n;++i)
			scanf("%d",&a[i]);
		dp[0]=0;
		for(i=1;i<=n;++i)
		{
			dp[i]=-INF;
			for(j=0;j<i;++j)
			{
				if(a[i]>a[j])
					dp[i]=max(dp[i],dp[j]);
			}
			dp[i]+=a[i];
		}
		ans=-INF;
		for(i=1;i<=n;++i)
		{
			if(dp[i]>ans)
				ans=dp[i];
		}
		printf("%d\n",ans);
	}
	return 0;
} 




你可能感兴趣的:(HDOJ 1087 Super Jumping! Jumping! Jumping!(DP))