Climbing Worm
Problem Description
An inch worm is at the bottom of a well n inches deep. It has enough energy to climb u inches every minute, but then has to rest a minute before climbing again. During the rest, it slips down d inches. The process of climbing and resting then repeats. How long before the worm climbs out of the well? We'll always count a portion of a minute as a whole minute and if the worm just reaches the top of the well at the end of its climbing, we'll assume the worm makes it out.
Input
There will be multiple problem instances. Each line will contain 3 positive integers n, u and d. These give the values mentioned in the paragraph above. Furthermore, you may assume d < u and n < 100. A value of n = 0 indicates end of output.
Output
Each input instance should generate a single integer on a line, indicating the number of minutes it takes for the worm to climb out of the well.
Sample Input
Sample Output
题目大意
有一只毛毛虫想要从深坑爬出来,深度为n,一分钟爬u米,然后需要休息一分钟,休息的时候会下滑d米,问爬出来需要多长时间。
代码
#include<stdio.h>
int main()
{
int n,u,d;
int i,sum;
while(scanf("%d%d%d",&n,&u,&d),n)
{
sum=0;
for(i=1;;i++)
{
if(i%2==1)
sum+=u;
else
sum-=d;
if(sum>=n)
break;
}
printf("%d\n",i);
}
return 0;
}