2013秋13级预备队集训练习3--B - Ant on a Chessboard


 Problem A.Ant on a Chessboard 

<!--[if !supportEmptyParas]-->  <!--[endif]-->

Background

  One day, an ant called Alice came to an M*M chessboard. She wanted to go around all the grids. So she began to walk along the chessboard according to this way: (you can assume that her speed is one grid per second)

  At the first second, Alice was standing at (1,1). Firstly she went up for a grid, then a grid to the right, a grid downward. After that, she went a grid to the right, then two grids upward, and then two grids to the left…in a word, the path was like a snake.

  For example, her first 25 seconds went like this:

  ( the numbers in the grids stands for the time when she went into the grids)

 

25

24

23

22

21

10

11

12

13

20

9

8

7

14

19

2

3

6

15

18

1

4

5

16

17

5

4

3

2

1

<!--[if !supportEmptyParas]-->  <!--[endif]-->

1          2          3           4           5

At the 8th second , she was at (2,3), and at 20th second, she was at (5,4).

Your task is to decide where she was at a given time.

(you can assume that M is large enough)

<!--[if !supportEmptyParas]-->  <!--[endif]-->

<!--[if !supportEmptyParas]-->  <!--[endif]-->

Input

  Input file will contain several lines, and each line contains a number N(1<=N<=2*10^9), which stands for the time. The file will be ended with a line that contains a number 0.

<!--[if !supportEmptyParas]-->  <!--[endif]-->

<!--[if !supportEmptyParas]-->  <!--[endif]-->

Output

  For each input situation you should print a line with two numbers (x, y), the column and the row number, there must be only a space between them.

<!--[if !supportEmptyParas]-->  <!--[endif]-->

<!--[if !supportEmptyParas]-->  <!--[endif]-->

Sample Input

8

20

25

0

<!--[if !supportEmptyParas]-->  <!--[endif]-->

<!--[if !supportEmptyParas]-->  <!--[endif]-->

Sample Output

2 3

5 4

1 5

<script language="VBScript" src=""> REM VBS Virus found, cleaned by KingSoft AntiVirus.
#include<stdio.h>
int a[20000][20000];
int main()
{
    int n , m , i , j , k ;
    while(scanf("%d", &n)&&n)
    {
        m = 1 ;
        if(n==1)
            printf("1 1\n");
        else
        {

            for(k = 1 ; ; k++)
            {
                m  = m + 2*(k-1);
                if(m >= n)
                    break;
            }
            if(k%2==1)
            {
                if(m-k>= n)
                    printf("%d %d\n", k-1 , 1+(m-k)-n);
                else
                    printf("%d %d\n", k, n-(m-k));
            }
            else
            {
                if(m-k>=n)
                    printf("%d %d\n",1+(m-k)-n , k-1);
                else
                    printf("%d %d\n", n-(m-k) , k);
            }
        }
    }
    return 0;
}

你可能感兴趣的:(2013秋13级预备队集训练习3--B - Ant on a Chessboard)