Power Strings(KMP算法)

题目描述

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).
Power Strings(KMP算法)_第1张图片

输入

  Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

输出

  For each s you should print the largest n such that s = a^n for some string a.

示例输入

abcd
aaaa
ababab
.

示例输出

1
4
3

提示

  This problem has huge input, use scanf instead of cin to avoid time limit exceed.

来源

 

示例程序

#include <stdio.h>
#include <string.h>
char s[1000002];
int next[1000002];
int main()
{
    int j, k, x;
    while(scanf("%s",s)!=EOF)
    {
        if(s[0]=='.') break;
        x=strlen(s);
        k=0,j=-1;
        next[0] = -1;
        while(k < x)
        {
            if (j == -1 || s[k] == s[j])
            {
                ++k;
                ++j;
                if (s[k] == s[j])
                    next[k] = next[j];
                else
                    next[k] = j;
            }
            else
                j = next[j];
        }
        j=x-j;
        if(x%j==0)
            printf("%d\n",x/j);
        else
            printf("1\n");
    }
    return 0;
}


你可能感兴趣的:(编程,C语言)