1412111358-hd-Text Reverse

Text Reverse

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17738    Accepted Submission(s): 6729


Problem Description
Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.
 

Output
For each test case, you should output the text which is processed.
 

Sample Input
   
   
   
   
3 olleh !dlrow m'I morf .udh I ekil .mca
 

Sample Output
   
   
   
   
hello world! I'm from hdu. I like acm.
Hint
Remember to use getchar() to read '\n' after the interger T, then you may use gets() to read a line and process it.
 题目大意
        给多组英文句子,然后将句子中的每个单词的字母逆序输出
解题思路
        存入数组一次判断,遇到空格则将子连逆序输出并清空子连,否则将其存入子连。
代码
#include<stdio.h>
#include<string.h>
char a[1100],b[1100];
int main()
{
	int n;
	int len,nowl;
	int i,j,k,l;
	scanf("%d",&n);
	getchar();
	while(n--)
	{
		gets(a);
		len=strlen(a);
		for(nowl=0,i=0;i<len;i++)
		{
			if(a[i]!=' ')
			{
				b[nowl]=a[i];
				nowl++;
			}
			else
			{
				for(j=nowl-1;j>=0;j--)
				    printf("%c",b[j]);
				printf(" ");
				nowl=0;
			}
		}
		//因为上面的循环是到len即截至,所以还会有一个子连存在数组b中但是并没有输出 
		for(j=nowl-1;j>=0;j--)
		    printf("%c",b[j]);
		printf("\n");
	}
	return 0;
} 


你可能感兴趣的:(1412111358-hd-Text Reverse)