数据结构实验之链表二:逆序建立链表

题目描述

输入整数个数N,再输入N个整数,按照这些整数输入的相反顺序建立单链表,并依次遍历输出单链表的数据。

输入

第一行输入整数N;;
第二行依次输入N个整数,逆序建立单链表。

输出

依次输出单链表所存放的数据。

示例输入

10
11 3 5 27 9 12 43 16 84 22 

示例输出

22 84 16 43 12 9 27 5 3 11 

提示

#include <stdio.h>
#include <stdlib.h>
using namespace std;

struct node
{
    int n;
    struct node *next;
}*head;
int main()
{
    int n, i;
    scanf("%d",&n);
    for(i = 0; i <n; i++)
    {
        node *p = new node;
        scanf("%d",&p->n);
        p ->next = head;
        head = p;
    }
    for(node *a=head; a !=NULL; a= a->next)
    {
        printf("%d ", a->n);
    }
    return 0;
}


你可能感兴趣的:(编程,C语言)