1410010855-ny-Dinner

Dinner

时间限制: 100 ms  |           内存限制: 65535 KB
难度: 1
描述
Little A is one member of ACM team. He had just won the gold in World Final. To celebrate, he decided to invite all to have one meal. As bowl, knife and other tableware is not enough in the kitchen, Little A goes to take backup tableware in warehouse. There are many boxes in warehouse, one box contains only one thing, and each box is marked by the name of things inside it. For example, if "basketball" is written on the box, which means the box contains only basketball. With these marks, Little A wants to find out the tableware easily. So, the problem for you is to help him, find out all the tableware from all boxes in the warehouse.
输入
There are many test cases. Each case contains one line, and one integer N at the first, N indicates that there are N boxes in the warehouse. Then N strings follow, each string is one name written on the box.
输出
For each test of the input, output all the name of tableware.
样例输入
3 basketball fork chopsticks
2 bowl letter
样例输出
fork chopsticks
bowl
题目大意
       小A是ACM小组的一个成员。他刚刚在世界最终赢得金牌。为了庆祝,他决定邀请所有人吃一顿饭。当碗等餐具,刀不在厨房里的话,少去备份餐具仓库。有仓库多盒,一盒包含只有一件事,每个盒子的里面的东西的名称标记。例如,如果“篮球”写在盒上,这意味着这个箱子里只有篮球。这些标志,小的要容易找到餐具。所以的问题是要帮助他发现所有的餐具都从盒中的仓库

输入

输入

There are many test cases. Each case contains one line, and one integer N at the first, N indicates that there are N boxes in the warehouse. Then N strings follow, each string is one name written on the box.

有很多的测试用例。每个案例包含一个线,和一个整数N在第一,N表示,仓库里有N盒。然后N的字符串跟随每个字符串一个名字写在盒

输出

输出

For each test of the input, output all the name of tableware.

对于每个测试的输入输出所有名字的餐具

代码

#include<stdio.h>
#include<string.h>
char s[6][12];
char d[100][12];
char c[100];
void tableware()
{
	strcpy(s[0],"bowl");
	strcpy(s[1],"knife");
	strcpy(s[2],"fork");
	strcpy(s[3],"chopsticks");
}
int main()
{
	int n;
	int i,j,k;
	tableware();
	while(scanf("%d",&n)!=EOF)
	{
		getchar();
		k=0;
		for(i=0;i<n;i++)
		{
			scanf("%s",c);
			for(j=0;j<4;j++)
				if(strcmp(c,s[j])==0)
				{
					strcpy(d[k],c);
					k++;
					break;
				}
		}
		for(i=0;i<k;i++)
		{
			printf("%s",d[i]);
			if(i!=k)
			    printf(" ");
		}
		printf("\n");
	}
	return 0;
}


 

你可能感兴趣的:(1410010855-ny-Dinner)