1025 - A Spy in the Metro

1025 - A Spy in the Metro

Secret agent Maria was sent to Algorithms City to carry out an especially dangerous mission. After several thrilling events we find her in the first station of Algorithms City Metro, examining the time table. The Algorithms City Metro consists of a single line with trains running both ways, so its time table is not complicated.
Maria has an appointment with a local spy at the last station of Algorithms City Metro. Maria knows that a powerful organization is after her. She also knows that while waiting at a station, she is at great risk of being caught. To hide in a running train is much safer, so she decides to stay in running trains as much as possible, even if this means traveling backward and forward. Maria needs to know a schedule with minimal waiting time at the stations that gets her to the last station in time for her appointment. You must write a program that finds the total waiting time in a best schedule for Maria. The Algorithms City Metro system has N stations, consecutively numbered from 1 to N. Trains move in both directions: from the first station to the last station and from the last station back to the first station. The time required for a train to travel between two consecutive stations is fixed since all trains move at the same speed. Trains make a very short stop at each station, which you can ignore for simplicity. Since she is a very fast agent, Maria can always change trains at a station even if the trains involved stop in that station at the same time.
1025 - A Spy in the Metro_第1张图片

Input

The input file contains several test cases. Each test case consists of seven lines with information as follows.
Line 1. The integer N(2N50) , which is the number of stations.

Line 2. The integer T(0T200) , which is the time of the appointment.

Line 3. N1 integers: t1,t2,...,tN1(1ti20) , representing the travel times for the trains between two consecutive stations: t1 represents the travel time between the first two stations, t2 the time between the second and the third station, and so on.

Line 4. The integer M1(1M150) , representing the number of trains departing from the first station.

Line 5. M1 integers: d1,d2,...,dM1(0di250anddi<di+1) , representing the times at which trains depart from the first station.

Line 6. The integer M2(1M250) , representing the number of trains departing from the Nth station.
Line 7. M2 integers: e1,e2,...,eM2(0ei250andei<ei+1) representing the times at which trains depart from the Nth station. The last case is followed by a line containing a single zero.

Output

For each test case, print a line containing the case number (starting with 1) and an integer representing the total waiting time in the stations for a best schedule, or the word ‘impossible’ in case Maria is unable to make the appointment. Use the format of the sample output.

Sample Input

4
55
5 10 15
4
0 5 10 20
4
0 5 10 15
4
18
1 2 3
5
0 3 6 10 12
6
0 3 5 7 12 15
2
30
20
1
20
7
1 3 5 7 11 13 17
0

Sample Output

Case Number 1: 5
Case Number 2: 0
Case Number 3: impossible

某城市的地铁是线性的,有 n2n50 个车站,从左到右编号为 1n 。有 M1 辆列车从第 1 站开始往右开,还有 M2 辆列车从第 n 站开始往左开。在时刻 0 ,Mario从第 1 站出发,目的是在时刻 T0T200 会见车站n的一个间谍。在车站等车时容易被抓,所以她决定尽量躲在开动的火车上,让在车站等待的总时间尽量短。列车靠站停车时间忽略不计,且Mario身手敏捷,即使两辆方向不同的列车在同一时间靠站,Mario也能完成换乘。
1025 - A Spy in the Metro_第2张图片
输入第 1 行为 n ,第 2 行为 T ,第3行有 n1 个整数 t1,t2,,tn11ti70 ,其中ti表示地铁从车站 i i1 的行驶时间(两个方向一样)。第4行为 M11M150 ,即从第 1 站出发向右开的列车数目。第 5 行包含 M1 个整数 d1,d2,,dM10di250didi1 ,即各列车的出发时间。第 6 7 行描述从第 n 站出发向左开的列车,格式同第 4 5 行。输出仅包含一行,即最少等待时间。无解输出 impossible

#include <iostream>
#include <algorithm>
#include <cstring>

using namespace std;

const int INF = 10000000;
const int MAX_TIME = 200 + 5;
const int MAX_STATION = 50 + 5;

int kase = 0;
// 站的个数
int N;
// 会面时间
int T;

// has_train[t][i][0],表示t时刻,在车站i是否有往右开的火车
// has_train[t][i][1],表示t时刻,在车站i是否有往左开的火车
int has_train[MAX_TIME][MAX_STATION][2];

void initHasTrain(int *t) {
    // 预处理
    memset(has_train, 0, sizeof(has_train));
    // 火车离开起始点的时间
    int d;
    // 向右从1->N站点的火车个数
    int M1;
    cin >> M1;
    while(M1--) {
        cin >> d;
        for(int j = 1; j <= N - 1; j++) {
            if(d <= T) {
                has_train[d][j][0] = 1;
            }
            d += t[j];
        }
    }
    // 向左从N->1站点的火车个数
    int M2;
    cin >> M2;
    while(M2--) {
        cin >> d;
        for(int j = N - 1; j >= 1; j--) {
            if(d <= T) {
                has_train[d][j + 1][1] = 1;
            }
            d += t[j];
        }
    }
}

void solve(int *t) {
    // dp(i,j)表示时刻i,在车站j,最少还需要等待多长时间
    int dp[T + 1][N + 1];
    // 初始化dp
    for(int i = 1; i <= N - 1; i++) {
        dp[T][i] = INF;
    }
    // 边界条件
    dp[T][N] = 0;

    for(int i = T - 1; i >= 0; i--) {
        for(int j = 1; j <= N; j++) {
            // 等待1个单位,相当于花了1个单位的时间在等待火车上
            dp[i][j] = dp[i+1][j] + 1;
            // 向左
            if(j < N && has_train[i][j][0] && i + t[j] <= T) {
                dp[i][j] = min(dp[i][j], dp[i + t[j]][j + 1]);
            }
            // 向右
            if(j > 1 && has_train[i][j][1] && i + t[j - 1] <= T) {
                dp[i][j] = min(dp[i][j], dp[i + t[j - 1]][j - 1]);
            }
        }
    }

    // 输出
    cout << "Case Number " << ++kase << ": ";
    if(dp[0][1] >= INF) {
        cout << "impossible" << endl;
    } else {
        cout << dp[0][1] << endl;
    }
}

int main() {
    while(cin >> N && N) {
        cin >> T;
        // i代表第i个站点到第i+1个站点的行驶时间
        int t[N];
        for(int i = 1; i < N; i++) {
            cin >> t[i];
        }
        // 计算has_train数组
        initHasTrain(t);
        solve(t);
    }
    return 0;
}

你可能感兴趣的:(dp,动态规划,ACM,uva,uva1025)