jobdu1475 非常可乐

http://ac.jobdu.com/problem.php?pid=1457

时间限制:1 秒

内存限制:128 兆

特殊判题:

提交:537

解决:257

题目描述:

大家一定觉的运动以后喝可乐是一件很惬意的事情,但是seeyou却不这么认为。因为每次当seeyou买了可乐以后,阿牛就要求和seeyou一起分享这一瓶可乐,而且一定要喝的和seeyou一样多。但seeyou的手中只有两个杯子,它们的容量分别是N 毫升和M 毫升 可乐的体积为S (S<101)毫升(正好装满一瓶) ,它们三个之间可以相互倒可乐 (都是没有刻度的,且 S==N+M,101>S>0,N>0,M>0) 。聪明的ACMER你们说他们能平分吗?如果能请输出倒可乐的最少的次数,如果不能输出"NO"。

输入:

三个整数 : S 可乐的体积 , N 和 M是两个杯子的容量,以"0 0 0"结束。

输出:

如果能平分的话请输出最少要倒的次数,否则输出"NO"。

样例输入:
7 4 3
4 1 3
0 0 0
样例输出:
NO
3
#include <stdio.h>
#include <queue>
using namespace std;
struct N{
	int a, b, c;
	int t;
};
queue<N> Q;
bool mark[101][101][101];
void AtoB(int &a, int sa, int &b, int sb) {
	if (sb - b >= a){
		b += a;
		a = 0;
	}
	else{
		a -= sb - b;
		b = sb;
	}
}
int BFS(int s, int n, int m) {
	while (Q.empty() == false) {
		N now = Q.front();
		Q.pop();
		int a, b, c;
		a = now.a;
		b = now.b;
		c = now.c;
		AtoB(a, s, b, n);
		if (mark[a][b][c] == false){
			mark[a][b][c] = true;
			N tmp;
			tmp.a = a;
			tmp.b = b;
			tmp.c = c;
			tmp.t = now.t + 1;
			if (a == s / 2 && b == s / 2) return tmp.t;
			if (c == s / 2 && b == s / 2) return tmp.t;
			if (a == s / 2 && c == s / 2) return tmp.t;
			Q.push(tmp);
		}
		a = now.a;
		b = now.b;
		c = now.c;
		AtoB(b, n, a, s);
		if (mark[a][b][c] == false){
			mark[a][b][c] = true;
			N tmp;
			tmp.a = a;
			tmp.b = b;
			tmp.c = c;
			tmp.t = now.t + 1;
			if (a == s / 2 && b == s / 2) return tmp.t;
			if (c == s / 2 && b == s / 2) return tmp.t;
			if (a == s / 2 && c == s / 2) return tmp.t;
			Q.push(tmp);
		}
		a = now.a;
		b = now.b;
		c = now.c;
		AtoB(a, s, c, m);
		if (mark[a][b][c] == false){
			mark[a][b][c] = true;
			N tmp;
			tmp.a = a;
			tmp.b = b;
			tmp.c = c;
			tmp.t = now.t + 1;
			if (a == s / 2 && b == s / 2) return tmp.t;
			if (c == s / 2 && b == s / 2) return tmp.t;
			if (a == s / 2 && c == s / 2) return tmp.t;
			Q.push(tmp);
		}
		a = now.a;
		b = now.b;
		c = now.c;
		AtoB(c, m, a, s);
		if (mark[a][b][c] == false){
			mark[a][b][c] = true;
			N tmp;
			tmp.a = a;
			tmp.b = b;
			tmp.c = c;
			tmp.t = now.t + 1;
			if (a == s / 2 && b == s / 2) return tmp.t;
			if (c == s / 2 && b == s / 2) return tmp.t;
			if (a == s / 2 && c == s / 2) return tmp.t;
			Q.push(tmp);
		}
		a = now.a;
		b = now.b;
		c = now.c;
		AtoB(b, n, c, m);
		if (mark[a][b][c] == false){
			mark[a][b][c] = true;
			N tmp;
			tmp.a = a;
			tmp.b = b;
			tmp.c = c;
			tmp.t = now.t + 1;
			if (a == s / 2 && b == s / 2) return tmp.t;
			if (c == s / 2 && b == s / 2) return tmp.t;
			if (a == s / 2 && c == s / 2) return tmp.t;
			Q.push(tmp);
		}
		a = now.a;
		b = now.b;
		c = now.c;
		AtoB(c, m, b, n);
		if (mark[a][b][c] == false){
			mark[a][b][c] = true;
			N tmp;
			tmp.a = a;
			tmp.b = b;
			tmp.c = c;
			tmp.t = now.t + 1;
			if (a == s / 2 && b == s / 2) return tmp.t;
			if (c == s / 2 && b == s / 2) return tmp.t;
			if (a == s / 2 && c == s / 2) return tmp.t;
			Q.push(tmp);
		}
	}
	return -1;
}
int main(){
	int s, n, m;
	while (scanf("%d%d%d", &s, &n, &m) != EOF) {
		if (s == 0) break;
		if (s % 2 == 1){
			puts("NO");
			continue;
		}
		for (int i = 0; i <= s; i++){
			for (int j = 0; j <= n; j++){
				for (int k = 0; k <= m; k++){
					mark[i][j][k] = false;
				}
			}
		}
		N tmp;
		tmp.a = s;
		tmp.b = 0;
		tmp.c = 0;
		tmp.t = 0;
		while (Q.empty() == false) Q.pop();
		Q.push(tmp);
		mark[s][0][0] = true;
		int rec = BFS(s, n, m);
		if (rec == -1)
			puts("NO");
		else printf("%d\n", rec);
	}
	return 0;
}



你可能感兴趣的:(jobdu1475 非常可乐)