山东省第四届ACM大学生程序设计竞赛-Rescue The Princess(计算几何)

Rescue The Princess

Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

    Several days ago, a beast caught a beautiful princess and the princess was put in prison. To rescue the princess, a prince who wanted to marry the princess set out immediately. Yet, the beast set a maze. Only if the prince find out the maze’s exit can he save the princess.

    Now, here comes the problem. The maze is a dimensional plane. The beast is smart, and he hidden the princess snugly. He marked two coordinates of an equilateraltriangle in the maze. The two marked coordinates are A(x1,y1) and B(x2,y2). The third coordinate C(x3,y3) is the maze’s exit. If the prince can find out the exit, he can save the princess. After the prince comes into the maze, he finds out the A(x1,y1) and B(x2,y2), but he doesn’t know where the C(x3,y3) is. The prince need your help. Can youcalculate the C(x3,y3) and tell him?

输入

    The first line is an integer T(1 <= T <= 100) which is the number of test cases. T test cases follow. Each test case contains two coordinates A(x1,y1) and B(x2,y2), described by four floating-point numbers x1, y1, x2, y2 ( |x1|, |y1|, |x2|, |y2|<= 1000.0).
    Please notice that A(x1,y1) and B(x2,y2) and C(x3,y3) are in an anticlockwise direction from the equilateraltriangle. And coordinates A(x1,y1) and B(x2,y2) are given by anticlockwise.

输出

    For each test case, you should output the coordinate of C(x3,y3), the result should be rounded to 2 decimal places in a line.

示例输入

4
-100.00 0.00 0.00 0.00
0.00 0.00 0.00 100.00
0.00 0.00 100.00 100.00
1.00 0.00 1.866 0.50

示例输出

(-50.00,86.60)
(-86.60,50.00)
(-36.60,136.60)
(1.00,1.00)

提示

 

来源

2013年山东省第四届ACM大学生程序设计竞赛

题目意思:
给定A、B两个点的坐标,求另外一个点C,使得ABC构成一个等边三角形,且ABC三点是逆时针顺序。

解题思路如图(From 队友大神CXF):

山东省第四届ACM大学生程序设计竞赛-Rescue The Princess(计算几何)_第1张图片

注意到数学反三角函数double atan2 (double, double); 反正切(整圆值), 结果介于[-PI/2, PI/2]
区别于double atan (double); 反正切(主值), 结果介于[-PI/2, PI/2],因为斜率为零的情况 atan2不返回0而不是错误值。

/* 
* Copyright (c) 2016, 烟台大学计算机与控制工程学院 
* All rights reserved. 
* 文件名称:cal.cpp 
* 作    者:单昕昕 
* 完成日期:2016年4月9日 
* 版 本 号:v1.0 
*/  
#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
using namespace std;
const double PI=acos(-1.0);

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        double x1,y1,x2,y2;
        scanf("%lf%lf%lf%lf",&x1,&y1,&x2,&y2);
        double l=sqrt((y1-y2)*(y1-y2)+(x1-x2)*(x1-x2));
        double s=atan2(y2-y1,x2-x1);
        double l1=l*sin(s+(PI/3.0));
        double l2=l*cos(s+(PI/3.0));
        double x=x1+l2;
        double y=y1+l1;
        printf("(%.2lf,%.2lf)\n",x,y);
    }
    return 0;
}



你可能感兴趣的:(算法,C语言,poj,计算几何)