Beans
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1977 Accepted Submission(s): 997
Problem Description
Bean-eating is an interesting game, everyone owns an M*N matrix, which is filled with different qualities beans. Meantime, there is only one bean in any 1*1 grid. Now you want to eat the beans and collect the qualities, but everyone must obey by the following rules: if you eat the bean at the coordinate(x, y), you can’t eat the beans anyway at the coordinates listed (if exiting): (x, y-1), (x, y+1), and the both rows whose abscissas are x-1 and x+1.
Now, how much qualities can you eat and then get ?
Input
There are a few cases. In each case, there are two integer M (row number) and N (column number). The next M lines each contain N integers, representing the qualities of the beans. We can make sure that the quality of bean isn't beyond 1000, and 1<=M*N<=200000.
Output
For each case, you just output the MAX qualities you can eat and then get.
Sample Input
4 6
11 0 7 5 13 9
78 4 81 6 22 4
1 40 9 34 16 10
11 22 0 33 39 6
Sample Output
重点:
横竖分别求一下不连续的最大子段和;
#include <iostream>
using namespace std;
int beans[100][100],line[100],row[100];
int main() {
int m,n;
while(cin >> m >> n){
for(int i=0; i<m; i++){
cin >> beans[i][0] >> beans[i][1];
row[0] = beans[i][0];
row[1] = beans[i][1];
int tmpmax = max(row[0],row[1]);
row[1] = tmpmax;
for(int j=2; j<n; j++){
cin >> beans[i][j];
row[j] = max(row[j-2] + beans[i][j], row[j-1]);
}
line[i] = row[n-1];
}
int ans = max(line[0],line[1]);
line[1] = ans;
for(int i=2; i<m; i++){
line[i] = max(line[i-2] + line[i], line[i-1]);
// if(ans < line[i])
// ans = line[i];
}
cout << line[m-1] << endl;
}
return 0;
}