Max Sum
Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 10 Accepted Submission(s) : 9
Font: Times New Roman | Verdana | Georgia
Font Size: ← →
Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
Sample Output
Case 1:
14 1 4
Case 2:
7 1 6
Author
Ignatius.L
一开始容易想到的都是暴力方法,一个个向后面走,只要和大于max的就记录,但是会超时
for (i=1;i<= m;i++)
{
int sum=0;
for (int j= i;j<m;j++)
{
sum+=data [j];
if (sum>max)
{
max=sum;
point1=i;
point2=j;
}
}
}
可以用动态规划,对算法进行改进,起始还是从头开始,一直往后搜索,当遇到和小于0的时候,就对sum重新赋值,并把记录起始的点变为和为0的后一位,和不小于0的,就继续搜索下去.
#include <iostream>
using namespace std;
int main()
{
int T,n,i,max,num,sum;
int jilu1,jilu2,qian,hou;
//定义jilu1、jilu2为运算中记录起始整数位置,qian、hou为最后结果
cin>>T;
for(int k=1;k<=T;k++)
{
cin>>n;
sum=max=-1000;
qian=hou=1;
jilu1=jilu2=1;
for(i=1;i<=n;i++)
{
cin>>num;
if(sum>=0) {jilu2++;sum+=num;}
else if(sum<0)
{sum=num;jilu1=i;jilu2=i;}
//当前面集合为负数时,不用将前面数字加入计算和,直接令sum = 新输入元素
if(max<sum)
{
max=sum;
qian=jilu1;
hou=jilu2;
}
}
cout<<max<<‘ '<<qian<<‘ '<<hou<<endl;
if(k!=T)
cout<<endl;
}
return 0;
}