Bone Collector
Time Limit : 2000/1000ms (Java/Other) Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 58 Accepted Submission(s) : 25
Font: Times New Roman | Verdana | Georgia
Font Size: ← →
Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
Output
One integer per line representing the maximum of the total value (this number will be less than 2
31).
Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1
Sample Output
Author
Teddy
Source
HDU 1st “Vegetable-Birds Cup” Programming Open Contest
题意:用包按顺序收集骨头,给出包可收纳骨头的数量和各种骨头的数量及其价值,求可获得的最大价值。
思路:每种骨头按照包的剩余容量选择是否收集
状态:large[j]:表示收集了volume为j时的最大价值
状态转移:large[j]=max(large[j],large[j-volume[i]]+value[i])
#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
int main()
{
int i,j;
int t,n,v;
int large[1006],volume[1006],value[1006];
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&v);
for(i=1;i<=n;i++)
scanf("%d",&value[i]);
for(i=1;i<=n;i++) scanf("%d",&volume[i]);memset(large,0,sizeof(large));
for(i=1;i<=n;i++)
for(j=v;j>=volume[i];j--) large[j]=max(large[j],large[j-volume[i]]+value[i]);
printf("%d\n",large[v]);
}
return 0;
}