2007年NOIP提高组 统计数字

题目描述 Description
【问题描述】
某次科研调查时得到了n个自然数,每个数均不超过1500000000(1.5*109)。已知不相同的数
不超过10000 个,现在需要统计这些自然数各自出现的次数,并按照自然数从小到大的顺序输出统
计结果。

输入描述 Input Description
第1行是整数n,表示自然数的个数。
第2~n+1 行每行一个自然数。

输出描述 Output Description
输出包含m行(m为n个自然数中不相同数的个数),按照自然数从小到大
的顺序输出。每行输出两个整数,分别是自然数和该数出现的次数,其间用一个空格隔开。

样例输入 Sample Input
8
2
4
2
4
5
100
2
100

样例输出 Sample Output
2 3
4 2
5 1
100 2

看起来像桶,发现数据范围卡的死死的…,其实sort一边统计个数就好。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm> 
using namespace std;
int num[1000100];
int main()
{
    int n;
    scanf("%d",&n);
    for(int i = 1 ; i <= n ; i ++)
        scanf("%d",&num[i]);
    sort( num+1 , num+n+1 );
    int tot = 0;
    for(int i = 1 ; i <= n ; i ++)
    {
        if(num[i] != num[i-1])
            printf("%d",num[i]);
        if(num[i] != num[i+1])
        {
            printf(" %d\n",++tot);
            tot = 0;
        }
        else
        {
            tot ++;
        }
    }
    return 0;
}

传送门 :
codevs 1164
tyvj 1036

你可能感兴趣的:(sort)