HDU 4282 A very hard mathematic problem



Problem Description

  Haoren is very good at solving mathematic problems. Today he is working a problem like this: 
  Find three positive integers X, Y and Z (X < Y, Z > 1) that holds
   X^Z + Y^Z + XYZ = K
  where K is another given integer.
  Here the operator “^” means power, e.g., 2^3 = 2 * 2 * 2.
  Finding a solution is quite easy to Haoren. Now he wants to challenge more: What’s the total number of different solutions?
  Surprisingly, he is unable to solve this one. It seems that it’s really a very hard mathematic problem.
  Now, it’s your turn.
 


Input
  There are multiple test cases. 
  For each case, there is only one integer K (0 < K < 2^31) in a line.
  K = 0 implies the end of input.
  
 


Output
  Output the total number of solutions in a line for each test case.
 


Sample Input
   
   
   
   
9 53 6 0
 


Sample Output
   
   
   
   
1 1 0
思路:枚举y和次数z然后二分查找是否有符合条件的x出现y*y<2^31.
z增加值将是指数上涨所以时间复杂度为,log(k)*log(k)*sqrt(k)
#include<stdio.h>
typedef long long ll;
int cal(ll y,ll z,ll k)
{
    ll sum,l=1,flag=y-1;
    while(l<=flag)       
    {  ll x=(l+flag)/2,xz=1;
         for(int i=1;i<=z;i++)
          xz*=x;
        sum=xz+x*y*z;
        if(sum>k) flag=x-1;
        else if(sum==k) return 1;
        else l=x+1;
    }
    return 0;
}
int main()
{
    ll x,y,z;
    //freopen("e://in.txt","r",stdin);
    int icase,ans;
    while(scanf("%d",&icase)==1&&icase)
    {
        ans=0;y=2;z=2;
        for(y=2;y*y<=icase;y++)
            for(z=2;;z++)
         {
            ll yz=1;
        for(int i=1;i<=z;i++)
              yz*=y;
            if(yz>icase)
                break;
            else
                if(cal(y,z,icase-yz))
                   ans++;
        }
       printf("%d\n",ans);
    }
    return 0;
}

你可能感兴趣的:(二分法)