1004 Let the Balloon Rise【上升气球】题解

Let the Balloon Rise【上升气球】
说到上升气球,不禁想起了上升的气流#手动滑稽。

Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 118662 Accepted Submission(s): 46511

Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges’ favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) – the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input
5
green
red
blue
red
red
3
pink
orange
pink
0

Sample Output
red
pink

Author
WU, Jiazhi

Source
ZJCPC2004

意思就是统计一个颜色出现的频率,这些颜色都是小写单词,而且不超过15字。

于是乎我想到了映射,因为映射可以很方便的把一个字符串和整数对应起来。

AC代码:

#include<cstdio>
#include<iostream>
#include<map>
#include<string>
using namespace std;


int main(){
    int n;
    while(~scanf("%d",&n)&&n){
        map<string,int> mp;
        string tmp;
        for(int i=0;i<n;++i){
            cin>>tmp;
            if(mp.count(tmp))
                ++mp[tmp];
            else
                mp[tmp]=1;
        }
        int max=0;string color;
        for(map<string,int>::iterator it=mp.begin();it!=mp.end();++it){
                if(max<it->second){
                    max=it->second;
                    color=it->first;
                }
            }
        cout<<color<<endl;
    }   
}

你可能感兴趣的:(题解,c,ACM,HDU)