Hopscotch(枚举)

Hopscotch
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 1919   Accepted: 1375

Description

The cows play the child's game of hopscotch in a non-traditional way. Instead of a linear set of numbered boxes into which to hop, the cows create a 5x5 rectilinear grid of digits parallel to the x and y axes. 

They then adroitly hop onto any digit in the grid and hop forward, backward, right, or left (never diagonally) to another digit in the grid. They hop again (same rules) to a digit (potentially a digit already visited). 

With a total of five intra-grid hops, their hops create a six-digit integer (which might have leading zeroes like 000201). 

Determine the count of the number of distinct integers that can be created in this manner.

Input

* Lines 1..5: The grid, five integers per line

Output

* Line 1: The number of distinct integers that can be constructed

Sample Input

1 1 1 1 1
1 1 1 1 1
1 1 1 1 1
1 1 1 2 1
1 1 1 1 1

Sample Output

15

Hint

OUTPUT DETAILS: 
111111, 111112, 111121, 111211, 111212, 112111, 112121, 121111, 121112, 121211, 121212, 211111, 211121, 212111, and 212121 can be constructed. No other values are possible.

      题意:

      给出一个 5 X 5 的地图,从任意一个点出发,找出走 6 步可能的序列。输出总数。

 

      思路:

      DFS,每个点都暴搜一次,同时保存序列,判重即可。判重可以转成整数来判重就会更加简洁方便了。

   

      AC:

#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cstdlib>

int num[500000][10], fin[10];
int Map[10][10];
int dir[4][2] = {-1, 0, 0, -1, 1, 0, 0, 1};
int sum;

void dfs(int x, int y, int ans) {
        fin[ans] = Map[x][y];

        if (ans == 6) {
                for (int i = 1; i <= sum; ++i) {
                        int j;
                        for (j = 1; j <= 6; ++j) {
                                if (fin[j] != num[i][j]) break;
                        }
                        if (j == 7) return;
                }

                ++sum;
                for (int i = 1; i <= 6; ++i) {
                        num[sum][i] = fin[i];
                }

                return;
        }

        for (int i = 0; i < 4; ++i) {
                int nx = x + dir[i][0];
                int ny = y + dir[i][1];

                if (nx >= 1 && ny >= 1 &&
                    nx <= 5 && ny <= 5)
                    dfs(nx, ny, ans + 1);
        }
}

int main() {
        sum = 0;

        for (int i = 1; i <= 5; ++i) {
                for (int j = 1; j <= 5; ++j) {
                        scanf("%d", &Map[i][j]);
                }
        }

        for (int i = 1; i <= 5; ++i) {
                for (int j = 1; j <= 5; ++j) {
                        dfs(i, j, 1);
                }
        }

        printf("%d\n", sum);

        return 0;
}

 

 

你可能感兴趣的:(枚举)