ACboy needs your help(分组背包)

ACboy needs your help

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3109    Accepted Submission(s): 1619


Problem Description
ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the profit?
 

 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has.
Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j].
N = 0 and M = 0 ends the input.
 

 

Output
For each data set, your program should output a line which contains the number of the max profit ACboy will gain.
 

 

Sample Input
2 2
1 2
1 3
2 2
2 1
2 1
2 3
3 2 1
3 2 1
0 0
 

 

Sample Output
3 4 6

 

    题意:

    输入为多项,给出N门课程(1到100)和M天时间(1到100),随后给出一个N*M的矩阵,A[ i ][ j ]代表花费 j 天可以获得A[ i ][ j ]的分数。但是每门课程只能选一个时间,就是说每行只能选一个数。求在不超过有限时间内的最大成绩。

 

    思路:

    分组背包。

 

    AC:

#include<stdio.h>
#include<string.h>
int c[105][105];
int dp[105];
int main()
{
	int n,m;
	while(scanf("%d%d",&n,&m)!=EOF&&(n+m))
	{
	  memset(dp,0,sizeof(dp));
	  memset(c,0,sizeof(c));
	  for(int i=1;i<=n;i++)
		for(int j=1;j<=m;j++)
		  scanf("%d",&c[i][j]);
	  for(int i=1;i<=n;i++)
		for(int j=m;j>=0;j--)  
		   for(int k=1;k<=j;k++)  //一组中的每个都要进行一次01背包
			  dp[j]=(dp[j]>dp[j-k]+c[i][k]?dp[j]:dp[j-k]+c[i][k]);
	  printf("%d\n",dp[m]);
	}
	return 0;
}

 

 

 

你可能感兴趣的:(help)