Monthly Expense(二分搜索)

Monthly Expense
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 12941   Accepted: 5233

Description

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input

Line 1: Two space-separated integers:  N and  M 
Lines 2.. N+1: Line  i+1 contains the number of dollars Farmer John spends on the  ith day

Output

Line 1: The smallest possible monthly limit Farmer John can afford to live with.

Sample Input

7 5
100
400
300
100
500
101
400

Sample Output

500

Hint

If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.

 

     题意:

     给出 N(1 ~ 100000),M(1 ~ N),代表有 N 个数,要求将这 N 个数分成 M 堆,每一堆数的总和都有个 sum 值,使这个 sum 值最小。

 

     思路:

     二分搜索。设每堆数总和为 d 。区间设为左开右闭。

     若这个距离分出来的堆数 < m,说明值大了,应该搜索左边,则搜索 ( L , mid ];

     若这个距离分出来的堆数 > m,说明值小了,应该搜索右边,则搜索 ( mid , r ];

     若这个距离分出来的堆数 == m,说明这个值适合,但是还有可能出现更加小的,应该寻找第一个适合的值,所以应该搜索左边,( L , mid ]。

     最后输出的时候应该输出 r 的值,因为这是 左开右闭 的区间。

 

      AC:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

int mon[100005];
int n, m, masum, misum;

bool C(int d) {
        int now = 0, ans = 0;

        for (int i = 0; i < n; ++i) {
                now += mon[i];
                if (now > d) {
                        ++ans;
                        now = mon[i];
                }
        }

        if (now <= d) ++ans;

        return ans <= m;
}

void solve() {
        int l = misum - 1, r = masum;

        while(r - l > 1) {
                int mid = l + (r - l) / 2;
                if(C(mid)) r = mid;
                else l = mid;
        }

        printf("%d\n",r);
}

int main () {
       // freopen("test.in","r",stdin);

        masum = 0, misum = -1;
        scanf("%d%d", &n, &m);

        for (int i = 0; i < n; ++i) {
                scanf("%d",&mon[i]);
                masum += mon[i];
                misum = max(misum,mon[i]);
        }

        solve();

        return 0;
}

 

 

你可能感兴趣的:(exp)