DP-How to Type-2577


How to Type

Time Limit: 2000/1000 MS (Java/Others)Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2503Accepted Submission(s): 1171


Problem Description
Pirates have finished developing the typing software. He called Cathy to test his typing software. She is good at thinking. After testing for several days, she finds that if she types a string by some ways, she will type the key at least. But she has a bad habit that if the caps lock is on, she must turn off it, after she finishes typing. Now she wants to know the smallest times of typing the key to finish typing a string.

Input
The first line is an integer t (t<=100), which is the number of test case in the input file. For each test case, there is only one string which consists of lowercase letter and upper case letter. The length of the string is at most 100.

Output
For each test case, you must output the smallest times of typing the key to finish typing this string.

Sample Input
  
3 Pirates HDUacm HDUACM

Sample Output
  
8 8 8
Hint
The string “Pirates”, can type this way, Shift, p, i, r, a, t, e, s, the answer is 8. The string “HDUacm”, can type this way, Caps lock, h, d, u, Caps lock, a, c, m, the answer is 8 The string "HDUACM", can type this way Caps lock h, d, u, a, c, m, Caps lock, the answer is 8

on[i] 表示在大写开启时,输入第i个字符的最小敲键数。( on[0]=1, 因为大写默认关闭,所以第一次输入前,应该是敲一次开启 )

off[i] 表示在大写关闭时 .


如果是当前输入小写:

off[i] = min( off[i-1]+1,on[i-1]+2 );
表示,由前一个状态(off[i-1] 或 on[i-1] ), 输入当前字符,并要转化为当前的off状态,需要的最少敲键数。


#include <iostream>
#include <string>
using namespace std;

int main() {
	int t;
	cin >> t;
	string str;
	int on[105],off[105];
	while(t--){
		cin >> str;
		int len = str.length();
		for(int i=0; i<=len; i++){
			on[i] = 0;
			off[i] = 0;
		}
		on[0] = 1;
		for(int i=1; i<=len; i++){
			if(str[i-1] > 'Z'){ //小写
				off[i] = min( off[i-1]+1,on[i-1]+2 );
				on[i] = min(off[i-1]+2, on[i-1]+2);
			}else{ //大写
				off[i] = min( off[i-1]+2,on[i-1]+2 );
				on[i] = min(off[i-1]+2, on[i-1]+1);
			}


		}
		cout << min(off[len],on[len]+1) << endl;
	}
	return 0;
}





你可能感兴趣的:(type)