POJ ACM习题【No.1936】

All in All
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 11508 Accepted: 4497

Description

You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.

Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s.

Input

The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace.The length of s and t will no more than 100000.

Output

For each test case output "Yes", if s is a subsequence of t,otherwise output "No".

Sample Input

sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter

Sample Output

Yes
No
Yes
No

 

此题的解题思路为:

1.从字符串2中顺序取出字符,与字符串1中的字符进行顺序比对。

2.如果比对成功,双方游标加一,如果不成功字符串2游标加一。如果最终字符串2

3.如果某次比对成功时,字符串1的游标已至末尾,则返回成功

4.如果最终字符串2完成遍历,字符串1的游标仍未至末尾,则失败

 

import java.util.*;

public class Main {

	public static void main(String[] args) {
		Scanner cin = new Scanner(System.in);
		
		String[] str = new String[2];
		String a, b;
		boolean result;
		
		while(cin.hasNext())
		{
			str = cin.nextLine().split(" ");
			a = str[0];
			b = str[1];
			
			result = findit(a, b);
			if(result == true)
				System.out.println("Yes");
			else
				System.out.println("No");
		}
	}
	
	private static boolean findit(String lstr, String rstr)
	{
		char[] stra = lstr.toCharArray();
		char[] strb = rstr.toCharArray();
		
		int cura = 0;
		char curb = '\n';
		
		for(int j = 0; j < strb.length; j++)
		{
			curb = strb[j];
			if(curb != stra[cura])
				continue;
			else
			{
				if(cura == stra.length-1)
					return true;
				else
					cura ++;
			}
		}
		return false;
	}
}
 

你可能感兴趣的:(J#)