杭电1004

题目来源:杭电acm1004

Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.
 

 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.
 

 

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
 

 

Sample Input
      
5 green red blue red red 3 pink orange pink 0
 

 

Sample Output
      
red pink

 

这里使用hashMap,ArrayList集合。源程序如下:

import java.util.*;

public class P1004 {
    public static void main(String args[]){
        int count;
        String color;
       
        Map map = new HashMap<String,Integer>();
        Scanner sin = new Scanner(System.in);
        ArrayList<String> name = new ArrayList<String>();
        count = sin.nextInt();
       
        while(count!=0){
            for(int i=0;i<count;i++){
                color = sin.next();
                if(map.containsKey(color)){
                    Integer tempNum = (Integer)map.get(color);
                    tempNum = tempNum + 1;
                    map.remove(color);
                    map.put(color, tempNum);                               
                }
                else{
                    map.put(color, new Integer(1));
                    name.add(color);
                }           
            }
           
            String maxColor = name.get(0);
            int max = (Integer)map.get(maxColor);
            name.remove(0);
            while(!name.isEmpty()){
                if(max<(Integer)map.get(name.get(0))){
                    maxColor = name.get(0);
                    max = (Integer)map.get(maxColor);
                }
                name.remove(0);
            }
            System.out.println(maxColor);
            name.clear();
            map.clear();
               count = Integer.parseInt(sin.next());
        }
    }
}

你可能感兴趣的:(UP)