dp --- 最大子矩阵和

To The Max

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7593    Accepted Submission(s): 3679


Problem Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2

is in the lower left corner:

9 2
-4 1
-1 8

and has a sum of 15.
 

 

Input
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
 

 

Output
Output the sum of the maximal sub-rectangle.
 

 

Sample Input
4
0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
 

 

Sample Output
15
 

【题目大意】

首先输入一个数N,然后输入N*N的一个矩阵,要求输出最大子矩阵的和。

【题目链接】

http://acm.hdu.edu.cn/showproblem.php?pid=1081

【题目分析】

乍看题目意思很简单,但对于刚开始学DP的新手来说也不是很简单。

这道题使用到的算法是:矩阵压缩+最大连续子串和  (keambar大神说这不是矩阵压缩,是预处理,好像确实是这样,但也没多大影响,暂时就这样叫吧 =.=)

如果会做最大连续子串和,那么理解这题就相对简单一些,若不知道最大连续子串和,建议先看一下这两题:

http://acm.hdu.edu.cn/showproblem.php?pid=1003

http://acm.hdu.edu.cn/showproblem.php?pid=1231

这题的思想是求最大连续子串和的思想,不过这题是2维的,我们的可以将它转换为一维,然后再运用该思想求它的最大值!

如何将其转化为一维的呢?这就用到了矩阵压缩。

子矩阵必定也是由行和列组成,如上这个矩阵,它的行的组合有 1,1-2,1-3,1-4,2,2-3,2-4,3,3-4,4,无非这10种组合,这样,我们就可以将行进行压缩,比如说:1-2,我们将1,2行数据进行压缩,及进行合并。

   0 -2 -7 0
 +9  2 -6 2
-------------

   9 0 -13 2

那么这样我们就可以通过求最大连续子串和的思想求其最大值,为9

再看:2-4这个组合

     9 2 -6  2
    -4 1 -4  1
 +  -1  8  0 -2

----------------

    4  11 -10 1

所以它的最大和为15

这样通过压缩行,即将这个矩形的宽变为1,可以迅速的求出子矩阵的值,并求出最大值,因为求最大连续子串和思想是线性的,复杂度为O(N),所以可以快速求出压缩后矩阵的和!

下面是自己写的代码:(虽然有点暴力,但是过这题时间毫无压力)

# include<stdio.h>
# include<string.h>
int dp[105][105]; int map[105][105]; int main() { int i,j,n,i1,i2,sum,temp,max,res; while(scanf("%d",&n)!=EOF) { for(i=1;i<=n;i++) for(j=1;j<=n;j++) scanf("%d",&map[i][j]); memset(dp,0,sizeof(dp)); for(j=1;j<=n;j++) //控制列 for(i=1;i<=n;i++) //控制行 dp[j][i]=dp[j][i-1]+map[i][j]; //dp[j][i]代表第j列从第1行开始的数累加到到第i行的和 res=0; for(i1=1;i1<=n;i1++) //i1,i2控制行的组合 for(i2=i1;i2<=n;i2++) { max=sum=0; for(j=1;j<=n;j++) //j控制在该行组合下的列  { sum+=dp[j][i2]-dp[j][i1-1]; //表示第 j 列从第i1到i2行数字之和 if(sum>=0) //下面即为求最大连续子串和思想  { if(sum>=max) max=sum; } else sum=0; } if(max>=res) res=max; } printf("%d\n",res); } return 0; }

 

 

最大子矩阵

Time Limit: 30000/10000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2743    Accepted Submission(s): 1391


Problem Description
给你一个m×n的整数矩阵,在上面找一个x×y的子矩阵,使子矩阵中所有元素的和最大。
 

 

Input
输入数据的第一行为一个正整数T,表示有T组测试数据。每一组测试数据的第一行为四个正整数m,n,x,y(0<m,n<1000 AND 0<x<=m AND 0<y<=n),表示给定的矩形有m行n列。接下来这个矩阵,有m行,每行有n个不大于1000的正整数。
 

 

Output
对于每组数据,输出一个整数,表示子矩阵的最大和。
 

 

Sample Input
1 4 5 2 2 3 361 649 676 588 992 762 156 993 169 662 34 638 89 543 525 165 254 809 280
 

 

Sample Output
2474
 

 

Author
lwg
 

【题目分析】

这题和上一题有些许不同,这题在题目中明确说给的每个数都是正整数,这就意味着我们不需要去处理负数的情况。解决这题有一个很巧妙的方法。详看代码。

 

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<math.h>
#define MAX(a,b) (a>b?a:b)
#define MIN(a,b) (a<b?a:b)
int dp[1010][1010];
int main()
{
    int T,i, j,  m, n, x, y, a, max, sum;
    scanf("%d",&T);
    while(T--)
    {
        max = 0;
        memset(dp,0,sizeof(dp));
        scanf("%d%d%d%d",&m,&n,&x,&y);
        for(i = 1; i <= m; i++)
        {
            for(j = 1; j <= n; j++)
            {
                scanf("%d",&a);
                dp[i][j] = dp[i-1][j]-dp[i-1][j-1]+dp[i][j-1]+a;
                 if(i>=x && j >= y)
                    max = MAX(max,dp[i][j]-dp[i][j-y]-dp[i-x][j]+dp[i-x][j-y]);
            }
        }
        printf("%d\n",max);
    }
    return 0;
}

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

你可能感兴趣的:(dp)