POJ2386经典DFS深搜

/**
*@ author StormMaybin
*@ date 2016-09-27
*/

Description
Due to recent rains, water has pooled in various places in Farmer John’s field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water (‘W’) or dry land (‘.’). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John’s field, determine how many ponds he has.

Input
* Line 1: Two space-separated integers: N and M

  • Lines 2..N+1: M characters per line representing one row of Farmer John’s field. Each character is either ‘W’ or ‘.’. The characters do not have spaces between them.

Output
* Line 1: The number of ponds in Farmer John’s field.

Sample Input

10 12
W……..WW.
.WWW…..WWW
….WW…WW.
………WW.
………W..
..W……W..
.W.W…..WW.
W.W.W…..W.
.W.W……W.
..W…….W.

Sample Output

3

Hint
OUTPUT DETAILS:

There are three ponds: one in the upper left, one in the lower left,and one along the right side.

DFS实现

package com.stormma.poj;

import java.io.BufferedInputStream;
import java.util.Scanner;

public class Main2386
{

    /**
     * @param args
     */
    private Scanner scan = null;
    private int n;
    private int m;
    private char[][] maze;

    public Main2386()
    {
        scan = new Scanner(new BufferedInputStream(System.in));
        n = Integer.parseInt(scan.next());
        m = Integer.parseInt(scan.next());
        maze = new char [n][m];
        for (int i = 0; i < n; i++)
            maze[i] = scan.next().toCharArray();
        int ans = 0;
        for (int i = 0; i < n; i++)
        {
            for (int j = 0; j < m; j++)
            {
                if (maze[i][j] == 'W')
                {
                    dfs (i, j);
                    ans++;
                }
            }
        }
        System.out.println(ans);
    }
    public void dfs (int x, int y)
    {
        maze[x][y] = '.';

        for (int dx = -1; dx <= 1; dx++)
        {
            for (int dy = -1; dy <= 1; dy++)
            {
                int nx = x + dx;
                int ny = y + dy;
                if (0 <= nx && nx < n && 0 <= ny && ny < m && maze[nx][ny] == 'W')
                    dfs (nx, ny);
            }
        }
        return;
    }
    public static void main(String[] args)
    {
        // TODO Auto-generated method stub
        new Main2386();
    }
}

你可能感兴趣的:(ACMer之路,________水题,________搜索)