蓝桥杯 最短路(Java_超时)

问题描述 :  给定一个n个顶点,m条边的有向图(其中某些边权可能为负,但保证没有负环)。请你计算从1号点到其他点的最短 路(顶点从1到n编号)。
输入格式 : 第一行两个整数n, m。

   接下来的m行,每行有三个整数u, v, l,表示u到v有一条长度为l的边。

输出格式 : 共n-1行,第i行表示1号点到i+1号点的最短路。
样例输入
3 3
1 2 -1
2 3 -1
3 1 2
样例输出
-1
-2
数据规模与约定

对于10%的数据,n = 2,m = 2。

对于30%的数据,n <= 5,m <= 10。

对于100%的数据,1 <= n <= 20000,1 <= m <= 200000,-10000 <= l <= 10000,保证从任意顶点都能到达其他所有顶点。

注意:这题我超时了,不知道是我的SPFA()有问题,还是Java本身就过不了这个题(这题好像是C++组的题)。

 如果有大佬用Java做出来了,还希望可以分享一下

package cn.swust.edu.CR.Lan;

import java.util.*;
import java.math.*;

public class Mymain {
	
	static int[] dis;
	static boolean[] inq;
	static Array[] arr;
	static int n, m;
	
	
	public static void spfa() {
		Queue q = new LinkedList();
		q.add(1);
		dis[1] = 0;
		inq[1]=true;
//		System.out.println(q.size());
		while(q.peek()!=null) {
			int now = q.remove();
			inq[now] = false;
			for(Edge edge: arr[now].ArrayEdge) {
				if(dis[edge.to] > dis[now]+edge.value) {
					dis[edge.to] = dis[now]+edge.value;
					if(!inq[edge.to]) {
						q.add(edge.to);
						inq[edge.to] = true;
//						System.out.println(edge.to);
					}
				}
			}
//			System.out.println(q.size());
		}
	}
	
	public static void main(String args[]) {
		Scanner input = new Scanner(System.in);
		
		n = input.nextInt();
		m = input.nextInt();
		
		arr = new Array[n+1];
		dis = new int[n+1];
		inq = new boolean[n+1];
		
		for(int i=0; i<=n; i++) {
			arr[i] = new Array();
			dis[i] = Integer.MAX_VALUE; 
		}
		for(int i=0; i ArrayEdge = new ArrayList();
}
DIJ如下,与SPFA差不多
package cn.swust.edu.CR.Lan;

import java.util.*;
import java.math.*;

public class Main {
	
	static Array[] arr;
	static boolean[] flag;
	static int[] dis;
	static int n,m;
	
	public static void dij() {
		for(int i=0; i ArrayEdge = new ArrayList();
}












你可能感兴趣的:(蓝桥杯-java)