杭电1004

Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges’ favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.
Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) – the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.
Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
Sample Input

5
green
red
blue
red
red
3
pink
orange
pink
0

Sample Output

red
pink
解析:这个题用java非常好做 不用解释了吧

import java.util.HashMap;
import java.util.Iterator;
import java.util.Map.Entry;
import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        Scanner scanner = new Scanner(System.in);
        int n;
        HashMap ballons = new HashMap<>();
        String temp = null;
        while (scanner.hasNext()) {
            n = scanner.nextInt();
            if(n==0)
                break;
            ballons.clear();
            for (int i = 0; i < n; i++) {
                temp = scanner.next();
                if (ballons.containsKey(temp)) {
                    Integer count = ballons.get(temp);
                    count++;
                    ballons.put(temp, count);
                } else {
                    ballons.put(temp, 1);
                }
            }
            Iterator iter = ballons.entrySet().iterator();
            int max = -1;
            while (iter.hasNext()) {
                Entry entry = (Entry) iter.next();
                if (entry.getValue() > max) {
                    max = entry.getValue();
                    temp = entry.getKey();
                }
            }
            System.out.println(temp);
        }

    }

}

你可能感兴趣的:(java,ACM)