This article will show you how to mount cifs、nfs、iso、cdrom on IBM AIX.

1.Mount Windows Share:

Before you do,ensure that the cifs_fs has been installed:

   
   
   
   
  1. [root@dbserv1 /]# lslpp -l |grep bos.cifs_fs  
  2.   bos.cifs_fs.rte            7.1.0.0  COMMITTED  Runtime for SMBFS 
  3.   bos.cifs_fs.smit           7.1.0.0  COMMITTED  SMIT Interface for SMBFS 
  4.   bos.cifs_fs.rte            7.1.0.0  COMMITTED  Runtime for SMBFS 
  5.   bos.cifs_fs.smit           7.1.0.0  COMMITTED  SMIT Interface for SMBFS 

If the cifs_fs package doesn't install,please insert AIX first dvd into cdrom and run following command:

   
   
   
   
  1. [root@dbserv1 /]# install -a -d /dev/cd0 bos.cifs_fs 

Now,you can use smit tools to mount:

   
   
   
   
  1. [root@dbserv1 /]# smitty cifs_fs 

Mounting A Windows Share On AIX Using CIFS_第1张图片

Mounting A Windows Share On AIX Using CIFS_第2张图片

Or,you can use following command to mount:

   
   
   
   
  1. [root@dbserv1 /]# mkcifsmnt -f /share/cifs -d pub -h 172.16.255.192 -c 'jacky.lee' -p 'abc123/321' -t ro -N 
   
   
   
   
  1. -f:MountPoint 
  2. -d:RemoteShare 
  3. -h:RemoteHost 
  4. -c:user 
  5. -p:password 
  6. -t:Specifies whether file system should be mounted as read-only. 
  7. -N:Mounts the CIFS share with the options specified, but does not modify the /etc/filesystems file. 
   
   
   
   
  1. [root@dbserv1 /]# df /share/cifs 
  2. Filesystem    GB blocks      Free %Used    Iused %Iused Mounted on 
  3. 172.16.255.192:pub    135.68     81.07   41%        0     0% /share/cifs 
  4. [root@dbserv1 /]# ls /share/cifs/ 
  5. 70296C3F.BIN           IBM.AIX.v7.1-DVD1.iso  IBM.AIX.v7.1-DVD2.iso 
  6. [root@dbserv1 /]# mount 
  7.   node       mounted        mounted over    vfs       date        options       
  8. -------- ---------------  ---------------  ------ ------------ ---------------  
  9.          /dev/hd4         /                jfs2   Apr 14 12:52 rw,log=/dev/hd8  
  10.          /dev/hd2         /usr             jfs2   Apr 14 12:52 rw,log=/dev/hd8  
  11.          /dev/hd9var      /var             jfs2   Apr 14 12:52 rw,log=/dev/hd8  
  12.          /dev/hd3         /tmp             jfs2   Apr 14 12:52 rw,log=/dev/hd8  
  13.          /dev/hd1         /home            jfs2   Apr 14 12:53 rw,log=/dev/hd8  
  14.          /dev/hd11admin   /admin           jfs2   Apr 14 12:53 rw,log=/dev/hd8  
  15.          /proc            /proc            procfs Apr 14 12:53 rw               
  16.          /dev/hd10opt     /opt             jfs2   Apr 14 12:53 rw,log=/dev/hd8  
  17.          /dev/livedump    /var/adm/ras/livedump jfs2   Apr 14 12:53 rw,log=/dev/hd8  
  18.          /dev/fslv00      /software        jfs2   Apr 14 12:53 rw,log=/dev/hd8  
  19. 172.16.255.192 pub              /share/cifs      cifs   Apr 14 13:44 ro     

Or,excute following command:

   
   
   
   
  1. [root@dbserv1 share]#mount -v cifs -n candon123/'jacky.lee'/'abc123/321' -o wrkgrp=workgroup,fmode=755 /pub /share/cifs 
  2. [root@dbserv1 share]# df 
  3. Filesystem    GB blocks      Free %Used    Iused %Iused Mounted on 
  4. /dev/hd4           1.12      0.95   16%    10071     5% / 
  5. /dev/hd2           3.88      1.81   54%    46585    10% /usr 
  6. /dev/hd9var        0.75      0.54   28%     3631     3% /var 
  7. /dev/hd3           0.12      0.12    1%       62     1% /tmp 
  8. /dev/hd1           0.06      0.06    1%        7     1% /home 
  9. /dev/hd11admin      0.12      0.12    1%        5     1% /admin 
  10. /proc                 -         -    -         -     -  /proc 
  11. /dev/hd10opt       1.75      1.54   13%     4352     2% /opt 
  12. /dev/livedump      0.25      0.25    1%        4     1% /var/adm/ras/livedump 
  13. /dev/fslv00        5.00      3.01   40%        5     1% /software 
  14. /dev/cd0           3.13      0.00  100%  1640871   100% /share/cd 
  15. candon123:/pub    135.68     81.07   41%        0     0% /share/cifs 

2.Mount A ISO file:

   
   
   
   
  1. [root@dbserv1 /]# mklv -y dvd1 -t jfs2 rootvg 53   
  2. dvd1 
  3. [root@dbserv1 /]# lslv -l dvd1 
  4. dvd1:N/A 
  5. PV                COPIES        IN BAND       DISTRIBUTION   
  6. hdisk0            053:000:000   0%            000:000:000:053:000  
  7. [root@dbserv1 /]# cd share/cifs/ 
  8. [root@dbserv1 cifs]# dd if=IBM.AIX.v7.1-DVD1.iso of=/dev/dvd1 bs=10M 
  9. 257+0 records in. 
  10. 257+0 records out. 
  11. [root@dbserv1 cifs]# mount -v cdrfs -o ro /dev/dvd1 /share/iso1 
  12. [root@dbserv1 cifs]# df /share/iso1 
  13. Filesystem    GB blocks      Free %Used    Iused %Iused Mounted on 
  14. /dev/dvd1          3.13      0.00  100%  1640871   100% /share/iso1 
  15. [root@dbserv1 cifs]# ls /share/iso1/ 
  16. .Version      OSLEVEL       RPMS          p_w_picpath.data    ppc           usr 
  17. 7100-00       README.aix    bosinst.data  installp      root 
  18. [root@dbserv1 cifs]#  

3.Mount NFS:

   
   
   
   
  1. [root@dbserv1 share]# showmount -e 172.16.255.5 
  2. export list for 172.16.255.5: 
  3. /u02 *.* 
  4. [root@dbserv1 share]# mount 172.16.255.5:/u02 /share/nfs 
  5. [root@dbserv1 share]# ls /share/nfs/netbackup/ 
  6. NetBackup_7.5_LinuxR_x86_64 
  7. [root@dbserv1 share]# 

If you get 'vmount: Operation not permitted' error,you must do this:

   
   
   
   
  1. [root@dbserv1 share]# nfso -a 
  2.            client_delegation = 1 
  3.            nfs_max_read_size = 65536 
  4.           nfs_max_write_size = 65536 
  5.                  nfs_rfc1323 = 1 
  6.    nfs_securenfs_authtimeout = 0 
  7.     nfs_server_base_priority = 0 
  8.            nfs_server_clread = 1 
  9.       nfs_use_reserved_ports = 0 
  10.    nfs_v3_server_readdirplus = 1 
  11.     nfs_v4_fail_over_timeout = 0 
  12.                    portcheck = 0 
  13.            server_delegation = 1 
  14.              utf8_validation = 1 
  15. [root@dbserv1 share]# nfso -o nfs_use_reserved_ports=1 
  16. Setting nfs_use_reserved_ports to 1 

4.Mount CDROM:

   
   
   
   
  1. [root@dbserv1 /]# mount -v cdrfs -o ro /dev/cd0 /mnt 
  2. [root@dbserv1 /]# df /mnt 
  3. Filesystem    GB blocks      Free %Used    Iused %Iused Mounted on 
  4. /dev/cd0           3.13      0.00  100%  1640871   100% /mnt 
  5. [root@dbserv1 /]# ls /mnt/ 
  6. .Version      OSLEVEL       RPMS          p_w_picpath.data    ppc           usr 
  7. 7100-00       README.aix    bosinst.data  installp      root 
  8. [root@dbserv1 /]#  

Maybe you can configure cdromd to automatic mount cdrom like this:

   
   
   
   
  1. Edit /etc/cdromd.conf and append following line:
  2. [root@dbserv1 /]# grep -v '#' /etc/cdromd.conf|sed '1d'  
  3. device  cd0     /share/cd 
  4. [root@dbserv1 /]# refresh -s cdromd 
  5. [root@dbserv1 /]# df /share/cd 
  6. Filesystem    GB blocks      Free %Used    Iused %Iused Mounted on 
  7. /dev/cd0           3.13      0.00  100%  1640871   100% /share/cd 
  8. [root@dbserv1 /]#