Number Sequence
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 86102 Accepted Submission(s): 20423
Problem Description
A number sequence is defined as follows:
f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.
Given A, B, and n, you are to calculate the value of f(n).
Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
Output
For each test case, print the value of f(n) on a single line.
Sample Input
Sample Output
Author
CHEN, Shunbao
Source
当时别人问我这题,我最开始一看感觉是矩阵快速幂,回来后想想%7,因为7太小了,可能有规律,周期最大为48,突然想起来原来以前做过这个题
#include <stdio.h>
int main()
{
int i,j,A,B,f1,f2,f3,n;
while(scanf("%d%d%d",&A,&B,&n)!=EOF&&(A||B||n))
{
f1=1;
f2=1;
A=A%7;
B=B%7;
n=(n-3)%48+2;
for(i=2;i<=n;i++)
{
f3=(A*f2+B*f1)%7;
f1=f2;
f2=f3;
}
printf("%d\n",f2);
}
return 0;
}