hihocoder #1179 : 永恒游戏 暴力

#1179 : 永恒游戏

Time Limit: 20 Sec

Memory Limit: 256 MB

题目连接

http://hihocoder.com/problemset/problem/1179

Description

很久很久以前,当Rowdark还是个善良的魔法师时,他在一个n个点m条边的无向图上玩一个游戏。

开始时他在一些点上放些石子。每次Rowdark选择一个点A,要求点A上的石子数大于等于邻居点个数。然后对A的每个邻居B,将A上的一个石子移到B上。如果不能选出这样的点A,那么游戏结束。Rowdark想知道这个游戏会不会无限循环。为了使问题更简单,你只需要求出是否10万轮后游戏仍然继续。

Input

第一行两个整数n和m(1 ≤ n ≤ 200)。

第二行n个整数a0, a1 ... an-1表示每个点上的石子个数(0 ≤ ai ≤ 109)。

接下来m行,每行两个数x和y (x ≠ y, 0 ≤ x, y ≤ n - 1),表示在x和y之间有一条边。题目保证没有重边,且任意一个点都有邻居。

Output

如果Rowdark能玩超过100000轮,输出“INF”(不带引号),否则输出最多步数。

Sample Input

3 3
1 2 1
0 1
1 2
2 0

Sample Output

INF

HINT

 

题意

 

题解:

每次我们都暴力选择剩下权值最多的点就好了,如果所有点的权值都小于这个点的度数的话,那么我们就输出-1

代码:

 

#include <cstdio>
#include <cmath>
#include <cstring>
#include <ctime>
#include <iostream>
#include <algorithm>
#include <set>
#include <vector>
#include <sstream>
#include <queue>
#include <typeinfo>
#include <fstream>
#include <map>
#include <stack>
typedef long long ll;
using namespace std;
//freopen("D.in","r",stdin);
//freopen("D.out","w",stdout);
#define sspeed ios_base::sync_with_stdio(0);cin.tie(0)
#define test freopen("test.txt","r",stdin)
#define maxn 100001
#define mod 10007
#define eps 1e-9
const int inf=0x3f3f3f3f;
const ll infll = 0x3f3f3f3f3f3f3f3fLL;
inline ll read()
{
    ll x=0,f=1;char ch=getchar();
    while(ch<'0'||ch>'9'){if(ch=='-')f=-1;ch=getchar();}
    while(ch>='0'&&ch<='9'){x=x*10+ch-'0';ch=getchar();}
    return x*f;
}
//**************************************************************************************

vector<int> g[210];
long long a[210];
int deg[210];

int main() {
    int n, m;
    scanf("%d%d", &n, &m);
    for (int i = 0; i < n; i++) 
    {
        scanf("%lld", &a[i]);
    }
    for (int i = 0; i < m; i++) 
    {
        int u, v;
        scanf("%d%d", &u, &v);
        g[u].push_back(v);
        g[v].push_back(u);
        deg[u]++;
        deg[v]++;
    }
    for (int i = 0; i <= 100000; i++) 
    {
        int id = -1;
        for (int i = 0; i < n; i++) 
        {
            if (a[i] >= deg[i]) 
            {
                if (id == -1 || (a[i] - deg[i]) > (a[id] - deg[id])) 
                {
                    id = i;
                }
            }
        }
        if (id == -1) 
        {
            printf("%d\n", i);
            return 0;
        } 
        else 
        {
            for (int i = 0; i < g[id].size(); i++) 
            {
                a[id]--;
                int v = g[id][i];
                a[v]++;
            }
        }
    }
    puts("INF");
    return 0;
}

 

你可能感兴趣的:(code)