一、Route-Map使用的场合

        1)路由再分布的时候,对路由进行过滤,比使用distribute-list更灵活

        2)策略路由

        3)Nat

        2)BGP的路由策略的实现


二、Route-Map技能展示

        1)Route-Map 的组成结构

        2)Route-Map的配置语法

        3)Route-Map与路由重分发的结合使用

        4)Route-Map 与PBR policy based route (基于策略的路由)的使用


三、Route Map的操作规则

        1)Route-Map 由一组语句组成

        2)Route-Map 一旦找到匹配的语句,后续的操作将不再进行;

        3)Route-Map 语句的处理时自上而下的

        4)Route-Map 其中的顺序序列号将用来指定route map 的顺序,可以增加或者更改某条特定的语句


四、Route Map语句设计

   1)route-map  my-map permit 10 { match statements}{set statements}
   2) route-map  my-map deny 20 { match statements}{set statements}
   3)route-map  my-map permit 30 { match statements}{set statements}
   #其中my-map 是Map的名字   10、 20 、30 是Map的序号

五、Route-Map 语句命令格式

1)设置router-map 的名字和条件 Router(config)#route-map{名字}[ permit | deny ] [ sequence-number ]

2)定义匹配操作的条件Router(conf ing-router-map)# match  {conditions}

3)设置匹配成功的语句的动作 Router(config-route-map)#set  {conditions}


六、Route-Map与路由重分发的结合使用

1)router(config)#router opsf 10

2)router(config-touter)#redistribute  rip  subnets  route-map redis-rip

3)路由器上的关于route-map的配置

        access-list   23 permit 10.1.0.0   0.0.255.255

        access-list   29 permit 172.16.0.0   0.0.0.255

        access-list   37 permit 10.0.0.0   0.0.0.255

        route map redis-rip permit 10

                match ip address 23 29  #将匹配访问控制列表23、 29的地址的路由更新设置成类型1且度量值为500

                set metric 500

                set  metric-type type-1

4)和访问控制列表 37匹配的路由更新包不能重分发到ospf区域

Route map redis-rip deny 20

    match  ip  address 37

将不符合签名俩个语句的路由更新包全局允许重分发到ospf区域

route  map  redis-map permit 30

        set metric 5000

        set  metric-type    type-2

注意如果没有30这个条允许语句将会怎么样?


七、PBR policy  based  route( 基于策略的路由与route-map 的结合应用)

1)PBR与一般路由协议比如静态路由,RIP路由的区别

        PBR可以使用路由基于原地址来转发;但PBR实现路由策略,需要通过调用route-map来实现

        一般IP路由是基于目标网络或地址来进行路由转发

PBR的有点及配置--基于源地址的路由

    QOS

负载分担

PBR的配置

cisco(config-if)#ip policy  route-map [name of  route-map]

其实就是在接口上调用一个已经设置好的route-map


八、PBR的配置实例

Route-Map 的使用_第1张图片


1)RA的配置
RA(config)# access-list 1  permit  1.1.0.0   0.0.255.255   #定义特殊数据流

RA(config)# access-list 2  permit  1.2.0.0   0.0.255.255   #定义特殊数据流

RA(config)#route-map  equal-access permit 10  #定义route-map

RA(config-route-map)#match ip address 1

RA(config-route-map)#set ip default  next-hop 6.6.6.6 #强制下一跳地址为ISP A 的

RA(config-route-map)#route-map equal-access  permit 20

RA(config-route-map)#match ip address 2

RA(config-route-map)#set ip default  next-hop 7.7.7.7#强制下一跳地址为ISP B的

RA(config-route-map)#route-map equal-access  permit 30

RA(config-route-map)#set ip default  interface null 0 #将其他的源地址的路由都滞空

2)在接口上应用route-map
RA(config)#interface e0

RA(config-if)#ip address 1.1.1.1  255.255.255.0

RA(config-if)#ip policy route-map  equal-access#在E0上应用route-map

RA(config)#interface s0

RA(config-if)#ip address 6.6.6.5  255.255.255.0

RA(config)#interface s1

RA(config-if)#ip address 7.7.7.6  255.255.255.0

3) 验证

PBR show  ip policy  显示接口设置的route map信息

show  route-map [name] 显示route map 信息

Match   ip address
匹配访问列表或前缀列表


Match   ip length
根据分组的第三层长度进行匹配


Match   interface
匹配器下一跳为指定接口之一的路由


Match   ip next-hop
匹配器下一跳路由器地址获得防伪列表之一允许的路由


Match   metric
匹配具有指定度量值的路由


Match   route-type
匹配指定类型的路由


Match   community
匹配BGP共同体


Match   tag
根据路由的标记进行匹配

Route-map(cont)

Set   metric
设置路由协议的度量值


Set   metric-type
设置目标路由协议的值类型


Set   default interface
指定如何发送这样的分组


Set   interface
指定如何发送这样的分组


Set ip   default next-hop
指定转发的下一跳


Set ip   next-hop
指定转发的下一跳


Set   next-hop
指定下一跳的地址,指定BGP的下一跳